Apple Improves Logic Mac Pro Support

| News

Apple released Logic Pro and Logic Express 7.2.3 on Wednesday. The update to the audio editing applications fix performance issues on the Mac Pro and G5 Quad Power Mac. The updates require Logic 7.2.1 or 7.2.2 and Mac OS X 10.4.3 or higher, and are available through Software Update.

No Comments

Log-in to comment