Apple Updates Airport Extreme, Express Firmware

| News

Apple released firmware updates for both the Airport Extreme and Airport Express Basestations on Tuesday. The firmware updates address issues with Airtunes, Airport network performance and compatibility, problems with third party Internet routers, and fixes a potential Denial of Service (DoS) security flaw. They require Mac OS X 10.3.9, or 10.4.3 or higher, and are not compatible with older snow or graphite Basestations. The firmware updates may not show up in Software Update, but are available for download at the Apple Web site (Airport Extreme / Airport Express).

Sign Up for the Newsletter

Join the TMO Express Daily Newsletter to get the latest Mac headlines in your e-mail every weekday.

No Comments

Log-in to comment