AirPort Utility Adds Support for Dual-Band AirPort Express

| Product News

Apple released AirPort Utility 6.1 on Monday with support for the just updated AirPort Express. The new version of the Base Station configuration utility also added support for managing IPv6 settings.

AirPort Utility adds dual-band AirPort Express supportAirPort Utility adds dual-band AirPort Express support

The new AirPort Express Base Station added dual-band 802.11n support, dual Ethernet ports, and redesigned the case to look like a white version of the Apple TV.

Along with AirPort Utility 6.1, Apple also released Airport Utility 5.6.1 for Mac and Windows with support for the dual-band AirPort Express. The older version of AirPort Utility gives users the option of falling back to the more traditional interface instead of the heavily graphic interface version 6 offers.

The updates are available via the Software Update application, or as downloadable installers at the Apple Support website.

Sign Up for the Newsletter

Join the TMO Express Daily Newsletter to get the latest Mac headlines in your e-mail every weekday.

Comments

John Martellaro

I was unable to manually upgrade to APU 5.6.1 with the installer I downloaded AFTER I updated to APU 6.1 with Lion’s Software Update. I got a message saying the version isn’t supported.  If anyone else has this problem, let me know.

John Martellaro

According to Apple’s support page

http://support.apple.com/kb/DL1536

System requirements for APU 5.6.1 are: “Mac OS X 10.5.7 to 10.6.8”

Version 5.6 still runs in Lion.

Log-in to comment