Iconfactory: Twitterrific 4 for Mac on the Way

| Product News

The Iconfactory crew released a little teaser Monday showing just a taste of what’s in store for Twitterrific 4.0 for the Mac. The team isn’t saying exactly when the new version of the Twitter client will ship or how much it will cost, but they are saying “the app is real and it’s going to be great.”

Twitterrific 4.0 will require Mac OS X 10.6 or newer because of some of the new features it will include. The company’s Twitterrific client for the iPhone, iPod touch and iPad is already popular, as is Twitterrific 3 for the Mac, so no doubt user expectations are high.

Iconfactory’s first taste of Twitterrific 4

The teaser image Iconfactory is showing should look at least somewhat familiar to Twitterrific 3 users, although enough has changed to make it clear that version 4 will work differently on at least some levels.

Mac users interested in keeping up on what’s in store for Twitteriffic 4 can check out the Iconfactory Web site.

Sign Up for the Newsletter

Join the TMO Express Daily Newsletter to get the latest Mac headlines in your e-mail every weekday.

Comments

MacKeeper_fan_Mod

Twitterrific 4.0 will require Mac OS X 10.6 or newer because of some of the new features it will include.

Such things always annoyed me: new versions which have minimum of distinctions from old ones requires new operating system, new hardware or something else. You know, old version is deleted and if you don’t upgrade your computer, you won’t be able to use the service any more. It’s stupidness.
I’m not a great fun of Twitter but sometimes I go there. I think that I’ll be able to live without it. So, I won’t pay money for new version, it’s better to spend them for something more useful in real life.

Log-in to comment