MacSpeech Dictate 1.5.5 Adds Snow Leopard Compatibility

| Product News

MacSpeech announced the immediate availability of MacSpeech Dictate 1.5.5 on Tuesday. The update for the speech recognition and voice dictation application improved overall compatibility with Mac OS X 10.6, or Snow Leopard.

Version 1.5.5 also added a contextual menu for the Available Commands window and includes several bug fixes.

MacSpeech Dictate 1.5.5 requires Mac OS X 10.5.6 or higher and an Intel-based Mac. It is priced starting at US$199.

Sign Up for the Newsletter

Join the TMO Express Daily Newsletter to get the latest Mac headlines in your e-mail every weekday.

1 Comments

Ken Clayton

Login doesn’t recognize either my email address, username or password.

Log-in to comment