OS X clock wrong when rebooting from windows (bootcamp)

  • Posted: 02 August 2007 01:43 PM

    Whenever i reboot from my travels in the dark lands (windows bootcamp partition) my clock is about 6-7 hours behind. as soon as i open the time/date pref pane it resets itself. Any ideas?


    Im running 10.4.10 on a 2ghz macbook duo with 1gb sdram that i bought on the first of january.

    Signature

    ~Ben
    When you swim in the creek
    And an eel bites your cheek
    That’s a moray!

    The best vinyl skins for iPod, PSP, XBox and more!

         
  • Avatar

    Posted: 02 August 2007 02:13 PM #1

    It is probably setting to GMT.

    Known issue, because of how OS X and Windows treat time syncing differently.

    There is a registry hack to make XP act like OS X with regards to time.

    Signature

    Mac switchers see my profile for switching help…

         
  • Posted: 02 August 2007 03:27 PM #2

    Yes. Annoying. But little outside of Intruder’s suggested trickery to fix it.

    Signature

    Karate ni sente nashi

         
  • Avatar

    Posted: 02 August 2007 08:24 PM #3

    [quote author=“Intruder”]It is probably setting to GMT.

    Known issue, because of how OS X and Windows treat time syncing differently.

    There is a registry hack to make XP act like OS X with regards to time.

    Sounds about right to me.  You must be in the Pacific or Mountain time zone.  Eastern time is 4-5 hours off GMT, depending on daylight savings.  I think the only solution is a hack of the type described my Intruder.

    Signature

    According to statistics, half the world is below average intelligence
    "The power of accurate observation is commonly called cynicism by those who have not got it."-George Bernard Shaw
    "You can’t change that by gettin’ all…bendy."

         
  • Posted: 15 August 2009 04:58 PM #4

    I am having this problem now…how do I fix this?  What is a registry hack?  Is it hard/risky to impliment?  I use my mac at work and need to sometimes use bootcamp for dragon naturally speaking.  (It does work in parallels- but not as well as bootcamp)

         
  • Posted: 26 August 2009 03:49 PM #5

    In your Windows registry, you need to update the key:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation\RealTimeIsUniversal

    Once you get down there, the RealTimeIsUniversal setting should be a DValue of 1. That registry key tells Windows that the time of the internal clock kept in the NVRAM, where your settings are, is using Coordinated Universal Time (UTC), sometimes (incorrectly) referred to as Greenwich Mean Time (GMT).

    NOTE: I know this works for XP but I think it works for Vista, too. I have not used Win7 so don’t even ask! grin

    Scott