Make Parallels leave me alone!

  • Posted: 28 August 2008 06:21 PM

    I’ve got parallels installed solely so I can play starcraft. Honestly, that’s it.

    But, sometimes, for no reason that I can find, my .doc extensions will magically associate themselves with wordpad within windows within parallels instead of NeoOffice. (Meaning, if I double click a file on my mac desktop or wherever, with parallels closed - parallels will launch and fire up wordpad.)

    I’ve set .doc to open always with NeoOffice from within the Get Info tab of a .doc file, and clicked the little “Seriously, Change All files and I mean it this time” button to no avail. It sticks for a while, but eventually, as sure as I’ll find poison ivy in a national park… one day I’ll open a .doc file and it’ll launch windows via parallels.

    Is there anyway to convince finder to ignore everything in parallels (I’ve blocked every parallels folder I can find from being indexed) and a way to forbid extension attributions from being changed from within parallels? I don’t want it reaching outside of itself. I want it staying in the little parallels container and not impacting the rest of my system at all. It only exists so I can play starcraft.
    (Yes, I have a starcraft issue. I get that. lol)

    Thanks in advance.

         
  • Posted: 01 September 2008 04:11 PM #1

    I don’t have parallels myself, but I think you might have to reset your SmartSelect preferences in parallels. There is a post about it here .

    Off topic, but why don’t you just play starcraft in OS X?? Seems like a lot of trouble to install parallels and then windows just to play a game that plays perfectly well natively.

    Cheers, hope this helps.

         
  • Posted: 01 September 2008 04:25 PM #2

    [quote author=“Morto”]
    Off topic, but why don’t you just play starcraft in OS X?? Seems like a lot of trouble to install parallels and then windows just to play a game that plays perfectly well natively.

    A recent patch for the video card built into my macbook pro removed 256 color support for the macbook pro running newest version of leopard for me. The apple and blizzard forums have mentions of it and at present both companies seem to believe it’s the other company’s problem.

         
  • Posted: 01 September 2008 05:01 PM #3

    I should have figured as much! I encountered the same problem last night at a friend’s place. If you’re comfortable running package installers from the interweb (which you justifiably could not be) there is a guy who has posted a fix for this issue and wrapped it up into a nice little installer here . I ran it last night and played Starcraft until the sun came up on my modbook.

         
  • Posted: 04 September 2008 11:37 AM #4

    Re: Make Parallels leave me alone!

    Don’t use Parallels to play games. Codeweavers have a special version for PC games that is solely designed to do this job. No Windows required.

         
  • Posted: 04 September 2008 11:40 AM #5

    Re: Make Parallels leave me alone!

    [quote author=“simplerich”]I’ve got parallels installed solely so I can play starcraft. Honestly, that’s it.

    But, sometimes, for no reason that I can find, my .doc extensions will magically associate themselves with wordpad within windows within parallels instead of NeoOffice. (Meaning, if I double click a file on my mac desktop or wherever, with parallels closed - parallels will launch and fire up wordpad.)
    .

    I had the same problem (sort of) with .txt or .rtf files insisting on launching TextEdit rather than my preferred Bean. No matter how often I reset the preference.
    I finally cured it by archiving TextEdit and deleting the original. It will always be there if I need it (I never have) but meanwhile it doesn’t exist as far as the OS is concerned.
    Try the same for WordPad.

         
  • Posted: 04 September 2008 01:43 PM #6

    10.5.5 fixes the issue where computers with nvidia cards lost the ability to support the 256 color “option” that Starcraft requires. Right now, Starcraft just crashes without notification.

         
  • Avatar

    Posted: 04 September 2008 08:28 PM #7

    [quote author=“Anonymous”]10.5.5 fixes the issue where computers with nvidia cards lost the ability to support the 256 color “option” that Starcraft requires. Right now, Starcraft just crashes without notification.

    10.5.5?  10.5.5, what?

    Signature

    “A body in motion at a constant velocity will remain in motion until pushed out of bounds by the Strong Safety.”    ~  Issac Newton’s First Law of Physics

         
  • Posted: 05 September 2008 05:02 AM #8

    [quote author=“iJack”][quote author=“Anonymous”]10.5.5 fixes the issue where computers with nvidia cards lost the ability to support the 256 color “option” that Starcraft requires. Right now, Starcraft just crashes without notification.

    10.5.5?  10.5.5, what?

    lol

    I was thinking the same thing, had to check my version. Then decided I’d keep checking for updates non-stop until I got the update. hehehe