Safari blocked, but Firefox is not blocked, on same network

  • Posted: 26 February 2009 10:50 AM

    I am using my MacBook Pro on a windows network at the office.  It works flawlessly with one exception:  If I use Safari as my browser, in inevitably stops loading pages after a few minutes.  For example, I can go to http://www.macobserver.com and it will load fine.  When I click on “forums” in then hangs up while trying to load the page.  It does not give me an error message, it just continues to try loading the page. If I use Firefox, however, this behavior never happens and it works without problem.

    I only have this problem while on my office network.  If I use my Macbook on another network, Safari works flawlessly.  In fact, this behavior at my office started about 6 months ago, and prior to that Safari worked OK. 

    So obviously I think the problem has something to do with the way my network is configured at the office.  However, my IT people have no clue where to look because the problem is so bizarre and isolated to Safari.  All other internet applications work fine (streaming, torrentz, even “Back To my Mac” on MobileMe).

    Does anyone have any idea why Firefox would work but not Safari, on the same network??

         
  • Avatar

    Posted: 26 February 2009 11:13 AM #1

    It sounds like you have a network proxy issue. Does your office network use a proxy of some sort?

    Firefox would act differently, because while Safari’s network settings are consistent with those in System Prefs, Firefox handles its own network connection settings. So, it is quite possible that Firefox works because it is configured correctly, but the rest of your system isn’t. This would also explain why it only happens at work, since proxy settings only matter on networks that use them.

    Ask your IT department about network proxies and settings, then check your Mac’s network configuration.

    Hope this helps! grin

         
  • Avatar

    Posted: 26 February 2009 01:19 PM #2

    I had that problem. Try turning off “Warn when visiting a fraudulent website” in the Safari Security Preferences.

    Signature

    “Works of art, in my opinion, are the only objects in the material universe to possess internal order, and that is why, though I don’t believe that only art matters, I do believe in Art for Art’s sake.” E. M. Forster

         
  • Posted: 26 February 2009 02:41 PM #3

    MaxW - 26 February 2009 03:13 PM

    It sounds like you have a network proxy issue. Does your office network use a proxy of some sort?

    Firefox would act differently, because while Safari’s network settings are consistent with those in System Prefs, Firefox handles its own network connection settings. So, it is quite possible that Firefox works because it is configured correctly, but the rest of your system isn’t. This would also explain why it only happens at work, since proxy settings only matter on networks that use them.

    Ask your IT department about network proxies and settings, then check your Mac’s network configuration.

    Hope this helps! grin

    I looked at my settings, and both Firefox and OS X network settings are set to “no proxies.”  My IT people say proxies are not needed for internet access here.

         
  • Posted: 26 February 2009 02:42 PM #4

    Sir Harry Flashman - 26 February 2009 05:19 PM

    I had that problem. Try turning off “Warn when visiting a fraudulent website” in the Safari Security Preferences.

    Thanks for the suggestion.  I tried turning off this setting, but it did not solve the problem.

    But I agree that it seems the problem is that Safari must be checking or logging with some server that Firefox is not, and that particular server or site is blocked on my network.

    Does anyone know if Safari behaves differently in this manner?

         
  • Posted: 26 February 2009 02:59 PM #5

    Firefox or Safari are pointless in my organization.  Windows and IE are indelibly printed on the brains of the IT staff here, and no amount of complaining that they are shutting out Mac users from important company information will change anything.  I mean they can’t even post a link in an email that will work with anything other than IE in Windows.

    I’ve pretty much given up dealing with these OS bigots who think the world revolves around Windows and Windows ONLY.  Never mind that Macs easily do 50% of the work around here.

    /endrant

         
  • Avatar

    Posted: 26 February 2009 02:59 PM #6

    kugs - 26 February 2009 06:42 PM

    Thanks for the suggestion.  I tried turning off this setting, but it did not solve the problem.

    But I agree that it seems the problem is that Safari must be checking or logging with some server that Firefox is not, and that particular server or site is blocked on my network.

    Does anyone know if Safari behaves differently in this manner?

    When I was having that problem I searched on the Apple Discussion blog and quite a few people had the problem. That is where I got the tip to turn off “Warn when visiting a fraudulent website.”

    Also try emptying cache after turning off the security option. Anyway, I think that Safari checks with Google’s list of fraudulent websites and that it can take a good bit of time doing that.

    Keep us updated.

    Signature

    “Works of art, in my opinion, are the only objects in the material universe to possess internal order, and that is why, though I don’t believe that only art matters, I do believe in Art for Art’s sake.” E. M. Forster

         
  • Posted: 26 February 2009 03:45 PM #7

    I just spent 20 minutes on the phone with AppleCare.  They had me log in with different user accounts, reset safari, delete the plist files, etc.  Nothing fixed the problem. He said that there are known issues with OS X 10.5.6 that will be addressed in the next update, but when I explained my problem started long before I upgraded to 10.5.6 he had no answer. He wants me to reinstall Safari, which I know will not solve the problem.

    There has to be someone, somewhere at Apple, who understands how Safari handles page loading differently than Firefox.  That person could help me, but no one seems to know how to find that person.

         
  • Posted: 05 March 2009 10:17 PM #8

    If you do not have access to the router logs, you may not get very far. If you could get the It guys to troubleshoot, I would have them check the firewall logs to see what is being blocked. I have seen some instances where a web browser was trying to go to one site but in the background was also checking another site for info on the web site that the user was trying to go to - that traffic was being blocked so the page the user was trying to go to was not loading. I am not sure if Safari is doing this, but without access to the firewall logs, there is no way to tell.

         
  • Posted: 05 March 2009 11:25 PM #9

    rain3d - 06 March 2009 02:17 AM

    If you do not have access to the router logs, you may not get very far. If you could get the It guys to troubleshoot, I would have them check the firewall logs to see what is being blocked. I have seen some instances where a web browser was trying to go to one site but in the background was also checking another site for info on the web site that the user was trying to go to - that traffic was being blocked so the page the user was trying to go to was not loading. I am not sure if Safari is doing this, but without access to the firewall logs, there is no way to tell.

    I had the same thought, but my IT guys insist that there is no firewall in play and that I am connected directly to the internet.

    I actually got a hold of a Safari product engineer, and he admitted that Apple is aware of this problem and currently does not have a fix.  I provided capture data to him while duplicating the problem, so hopefully it will be of use.

         
  • Posted: 06 March 2009 12:01 AM #10

    Have you tried to verify that by checking your IP address on your machine? If you have a private IP address like 192.168.1.X or 10.10.10.X, you are not directly connected to the internet. If your IP address on your machine matches the address you see if you go to http://www.ipchicken.com then you are probably directly connected to the internet. If it does not, you are not.

         
  • Posted: 06 March 2009 11:43 AM #11

    rain3d - 06 March 2009 04:01 AM

    Have you tried to verify that by checking your IP address on your machine? If you have a private IP address like 192.168.1.X or 10.10.10.X, you are not directly connected to the internet. If your IP address on your machine matches the address you see if you go to http://www.ipchicken.com then you are probably directly connected to the internet. If it does not, you are not.

    You are correct.  I have a 192… address which does not match my IP address.  So clearly I’m going through a router.  Apple was concerned that I may be going through a proxy, but my IT people insist that we do not have any proxy servers.  I can ask them for a router log, but I’m pessimistic that it will lead to a solution because this is a problem with which they are not concerned….they chalk it up to a “mac incompatibility issue” which in this case, unfortunately, I have to agree.  If Firefox was displaying the same behavior, then I would blame it on my network, but since it’s only Safari then there is something strange going on.

         
  • Posted: 06 March 2009 07:37 PM #12

    I would think that your IT guys either don’t care about your problem and lied to you about not going through a router or they don’t know what they are doing. Either way, it sounds like it will be impossible to get help from them. If you look for your default gateway in the same area that you found the IP address, that is the router’s LAN IP address. It will most likely be something like 192.168.0.XXX, 192.168.1.XXX, depending on your subnet. You could try to put that into a browser (may have to use https:// if http:// does not work). Depending on if you want to confront them or not, you can tell them that you know that you are going through a router and not directly connected and see what they say.

    You may not be going through a proxy server, but going through a router could definitly be blocking you.

         
  • Posted: 07 March 2009 03:07 PM #13

    rain3d - 06 March 2009 11:37 PM

    I would think that your IT guys either don’t care about your problem and lied to you about not going through a router or they don’t know what they are doing. Either way, it sounds like it will be impossible to get help from them. If you look for your default gateway in the same area that you found the IP address, that is the router’s LAN IP address. It will most likely be something like 192.168.0.XXX, 192.168.1.XXX, depending on your subnet. You could try to put that into a browser (may have to use https:// if http:// does not work). Depending on if you want to confront them or not, you can tell them that you know that you are going through a router and not directly connected and see what they say.

    You may not be going through a proxy server, but going through a router could definitly be blocking you.

    The basic problem with my IT people is that once they here it’s a Mac they turn off their brains and consider it to be someone else’s problem.  I could probably convince them to help me troubleshoot it, but the fact that every other browser works without issue they will claim that whatever is blocking it is serving a security purpose and they will not want to disable it. 

    I’m hopeful that Apple can address the problem from their end.

    Thanks for your help.

         
  • Avatar

    Posted: 08 March 2009 04:27 AM #14

    Safari 4 Beta came out not too long ago. Have you tried that?