Epson printer driver problem

  • Posted: 05 September 2009 04:52 PM

    System info:
    24” iMac (early 2008) 3.06 GHz Intel Core 2 Duo, 4 GB RAM
    Epson Stylus CX9400Fax all-in-one (no other printers)
    10.6 via erase & install, Migration Assistant from 10.5.8 Time Machine backup

    First I should say my printer appears to be working fine, it prints and scans without any issues just as it did under Leopard. My problem is something “geekier”: some Epson process or something is spamming the console every 10 seconds with the following:

    9/5/09 12:38:04 PM    com.apple.launchd.peruser.502[170]    (com.epson.epw.agent[5709]posix_spawn("/Library/Printers/EPSON/InkjetPrinter/EPW/IJEPWAgent.app/Contents/MacOS/IJEPWAgent", ...): No such file or directory
    9
    /5/09 12:38:04 PM    com.apple.launchd.peruser.502[170]    (com.epson.epw.agent[5709]Exited with exit code1
    9
    /5/09 12:38:04 PM    com.apple.launchd.peruser.502[170]    (com.epson.epw.agentThrottling respawnWill start in 10 seconds 

    The referenced file, /Library/Printers/EPSON/InkjetPrinter/EPW/IJEPWAgent.app/Contents/MacOS/IJEPWAgent, does not, in fact, exist. The folder /Library/Printers/EPSON/InkjetPrinter/ does not exist, instead I have /Library/Printers/EPSON/InkjetPrinter2/ and there is no EPW folder in it. I checked a Time Machine backup from before the SL install and there was indeed an IJEPWAgent.app at that path under Leopard.

    I tried re-installing Snow Leopard but that did not change anything. Then I tried to re-do my printer setup: I turned off the printer, right-clicked on my printer in the Print & Fax Sys Prefs list and chose Reset Printing…, deleted all “epson” & “print” .plist files from ~/Library/Preferences, shut down, unplugged the USB cable from both machines and then re-plugged, turned on the iMac, opened Print & Fax Sys Prefs, turned on the printer and the model & driver info came right up.

    The console spew persisted at every stage. What is going on? Why is my system trying to launch an app that doesn’t exist?

         
  • Posted: 07 September 2009 05:32 PM #1

    This is a notorious problem with Epson printers that exists under other operating systems. For some reason, if you upgrade and the base operating system has a driver, which SL may have, Epson will move things around so not to interfere with that driver.

    You can fix this by opening the terminal and entering the following:

    sudo ln -/Library/Printers/EPSON/InkjetPrinter2 /Library/Printers/EPSON/InkjetPrinter 

    This will create a symbolic link from InkjetPrinter to point to InkjetPrinter2 allowing monitoring agent (which is what it is looking for) to start.

    Good luck!

    Scott

         
  • Posted: 07 September 2009 06:46 PM #2

    Thanks, but that didn’t work. It’s not a matter of an incorrect path, but that the application IJEPWAgent.app doesn’t exist in the InkjetPrinter2 directory or anywhere else on my SL system, so I can’t just point to it with a symlink.

    Your post seems to imply, though, that I’m supposed to have that app, and whatever is sending those messages to Console certainly thinks the app is supposed to be running.

    In my previous Leopard install, the app did live at the Library/Printers/EPSON/InkjetPrinter/EPW/IJEPWAgent.app path, so I could pull it from a Time Machine backup. That might stop the console messages but would it conflict with the newer drivers that SL installed and cause bigger problems?