A little rant…

  • Avatar

    Posted: 12 September 2010 11:55 AM

    It seems that Apple caters to people with older PC’s. They can run the latest version of iTunes or Safari with 9+ year old hardware and OS (Pentium III Processor - made in April of 2001 and Windows XP - released on October 25, 2001 and updated on August 25, 2004 to SP 2), yet my 5+ year old G5 iMac cannot (delivered to my house on July 29, 2005 with 10.4 installed). If you want to downgrade iTunes for any reason…good luck trying to find a place on the web to download the installer because Apple certainly will not help or allow others to help. I googled “Windows iTunes 5.0” and from the third listing on down I could find downloads of iTunes, try “Mac iTunes 5.0” and see what you find.

    I know I could run these programs if I upgraded to Leopard, but, I shouldn’t have to. I’m starting to feel like this guy: (warning: some mildly risqu? advertising on page)

    http://www.liveleak.com/view?i=45b_1245438109