Does anyone know how to??.

  • Posted: 16 February 2011 03:53 AM

    Change the sound preferences so that the default is to output to the audio line-out port on a Mac Pro running OS 10.6.6 ? Every time I reboot the sound defaults to play through the internal speakers & I have to go into system preferences then change them manually & it’s driving me Nuts !

    Cheers

    Peter

         
  • Avatar

    Posted: 16 February 2011 01:28 PM #1

    Have you tried SoundSource from http://www.rogueamoeba.com. It’s very useful on a Mac Pro for choosing the output. You can even (I know you’re not asking for this) configure it to route to the headphone jack if something’s plugged in.

         
  • Posted: 23 February 2011 05:53 AM #2

    Thanks for the info on Soundsource, I’ve installed it & it is useful, however I still have to manually select the output after boot up.

    Cheers

    Peter

         
  • Avatar

    Posted: 23 February 2011 09:01 AM #3

    My own Mac Pro is running Leopard (hope to upgrade it this week if I can afford the downtime) and doesn’t have that problem. I’m not saying it’s a Snow Leopard problem, only that I don’t have exactly the same setup as you, so my “It works fine for me” isn’t as useful. :)

    Ideas:

    1, What kind of device do you have attached to your audio output port? Is it possible that it’s not available at some point in the boot cycle, and the Mac just defaults to the internal speaker?

    2, (not a solution, I know) is it at least more convenient to use SoundSource to select the output at startup rather than System Preferences?

    I’m afraid I don’t have any other ideas than that.

         
  • Avatar

    Posted: 23 February 2011 09:04 AM #4

    Reset the parameter RAM (PRAM).

    When you reboot, hold down cmd-opt-p-r until it chimes the third time, then release the keys and let it boot normally.

    See if that works.

    Signature

    Mac switchers see my profile for switching help…

         
  • Posted: 25 February 2011 09:13 AM #5

    It looks like this is a common fault with Mac Pro’s running Snow leopard. I’ve quoted below an article I found at Mac Forums. Basically you delete two files,change the input so it’s as you want it, then restart. This seems to fix it

    Go to your hard drive (root level), and open the Library folder. Then open the Preferences folder, and open the Audio folder.

    Delete the two preference files contained in the Audio folder:
    - com.apple.audio.DeviceSettings.plist
    - com.apple.audio.SystemSettings.plist

    Now open Sound Preferences and set the preferences the way you want them.

    Close Sound Preferences

    Restart.

    Cheers

    Peter

         
  • Avatar

    Posted: 25 February 2011 09:51 AM #6

    Good find. Thanks.

    Signature

    Mac switchers see my profile for switching help…