Address book contacts duplicated after iCloud

  • Posted: 13 October 2011 01:28 PM

    Downloaded 10.7.2 last night and used my existing iTunes store account as the iCloud ID.

    Google Calendar sync can co-exist with iCloud Cal sync.  However, if you want to sync address book with iCloud, Google contacts sync is disabled. 

    Anyway, now that my Address book is syncing with iCloud I have duplicates of each contact if I click on All contacts.

    My contacts are listed once in the On My Mac category and also once in my On my iCloud category.

    When I click find duplicates, none are found.

    Is this normal?

         
  • Posted: 13 October 2011 10:01 PM #1

    I had the same problem. Had a senior tech support help me through for an hour and half. In the end I had to manually delete the duplicate’s which updated the cloud. I shut my mac down went from the office to home. Restarted and they were all back!

         
  • Posted: 13 October 2011 11:11 PM #2

    gibstr - 14 October 2011 01:01 AM

    I had the same problem. Had a senior tech support help me through for an hour and half. In the end I had to manually delete the duplicate’s which updated the cloud. I shut my mac down went from the office to home. Restarted and they were all back!

    All back meaning, you’re all set now?

    How about if I just deleted the iCloud contacts on the web?  Would this work?

    Are you mad that you can no longer sync with Google Contacts?  I am.

         
  • Posted: 13 October 2011 11:14 PM #3

    All back meaning contacts are duplicated again! I had to manually delete again but quite frankly afraid to turn off and restart as they may appear again.  I must have to do with a setting in my mac. Mobile me used to asked you which device would override, cloud hasnt given me that option.

         
  • Posted: 14 October 2011 01:41 AM #4

    gibstr - 14 October 2011 02:14 AM

    All back meaning contacts are duplicated again! I had to manually delete again but quite frankly afraid to turn off and restart as they may appear again.  I must have to do with a setting in my mac. Mobile me used to asked you which device would override, cloud hasnt given me that option.

    Wow—I am really ticked now!

    I unchecked the iCloud account from the Enable this account preference in Address Book—and my local contacts stayed—but, get this,  all of my groups are gone. 

    What?  I’m serious.

         
  • Avatar

    Posted: 14 October 2011 10:29 AM #5

    Sounds like a bug. Send it to .(JavaScript must be enabled to view this email address).

    Signature

    Mac switchers see my profile for switching help…

         
  • Posted: 14 October 2011 12:12 PM #6

    Mine was doing the same thing. I noticed that if while in Address Book, click “View”, “Groups”, you can switch between “All contacts”, “All on my Mac” and “All on iCloud”. Obviously, if you choose “All contacts”, you will be viewing contacts from both sources (duplicates).

    Hope this helps!

    Jim

         
  • Posted: 14 October 2011 12:17 PM #7

    yes apparently tech support stated that only icloud should appear if you are syncing there?  I would expect that all of my contacts would sync with the cloud so why would I want to see duplicates “on my mac”? I have to check in with them again today when I get to the office. I have a direct line to the person that stated this yesterday.

         
  • Posted: 14 October 2011 12:32 PM #8

    Well, logically thinking, and this is my understanding only, when a person configures iCloud to **sync** with the Mac Address Book, what is it really doing? Well, it’s synchronizing the contacts in iCloud with your Mac’s Address Book which means the contacts are now the same in both places. All that is needed is to configure your address book to view only the source that you wish to see.

    if you don’t want to bother with that, you can always login to iCloud.com and view your data from a single source.

    Please let us know what Apple support says.

    Jim

         
  • Posted: 14 October 2011 07:59 PM #9

    Ok—I have fixed the issue.

    I deleted the web copy of iCloud contacts, after I had disabled that “Account” in Address Book.  However, a local iCloud copy (different from the Local On my Mac copy) still existed. 

    I deleted that by clicking on the minus button in AddressBook preferences Accounts.

    Then I went into Sys Prefs.  iCloud—and re-checked Address Book.

    BINGO.  it’s all great now.  Just one local (and online copy) in Address Book under the master heading, iCloud.

         
  • Posted: 16 October 2011 04:20 PM #10

    Great find, kbvictory!

    I followed your instructions and it worked perfect!

    Thanks for the follow up,

    Jim

         
  • Posted: 17 October 2011 06:23 PM #11

    @kbvictory, I believe the quickest fix is to select in the group view all of your local mac addresses, and then delete them.

    Here’s more details about how to fix it.
    Hopefully this helps.

         
  • Posted: 20 October 2011 06:09 PM #12

    kbvictory - 14 October 2011 10:59 PM

    Ok—I have fixed the issue.

    I deleted the web copy of iCloud contacts, after I had disabled that “Account” in Address Book.  However, a local iCloud copy (different from the Local On my Mac copy) still existed. 

    Sorry to be obtuse, but what is “the web copy of iCloud contacts”? Do I find that in my address book, or where?

         
  • Posted: 17 November 2011 07:55 AM #13

    I’m glad to hear you fixed the issue. such issues can also rise with jailbreaked devices. The process can be reversed, but back up data and reinstall iCloud. Here’s a quick icloud setup guide for jailbreaked devices in case you need it… Cheers!