Problems with latest ver. Firefox

  • Avatar

    Posted: 03 August 2012 09:05 PM

    +

    The latest version of Firefox on both Macs and PCs can’t seem to display social media feeds from Facebook and Twitter on websites I’ve built, my own being one of them. Worse yet, slide shows on my sites, using commercial software (Frontpage Slideshow), display incorrectly (Firefox OS X only) as images stacked on top of one another down the page, rather than images fading from one to the next.

    Safari for OS X is my browser of choice. For Firefox users out there, are you having trouble viewing websites following recent Firefox upgrades? FWIW, my sites all display properly on OS X Safari and Chrome, and Windows Explorer. Thanks.

    Signature

    mrmwebmax (formerly mrmgraphics)
    Max out your site! mrmwebmax.com

         
  • Posted: 09 August 2012 01:28 PM #1

    Which exact version of Firefox are you using? I wonder if there is some security setting that has been set too restrictive?

    I just visited the site in your signature using Firefox 14.0.1 on Mountain Lion. The Facebook and Twitter feeds in your sidebar loaded just fine.

         
  • Avatar

    Posted: 09 August 2012 01:34 PM #2

    +

    David,

    I’m running 14.0.1 in Snow Leopard. I found that the Facebook and Twitter feed issue could be resolved by turning off “Block Caching” within my website’s Drupal control panel. The slide shows have been the bigger issue. When you logged onto my site, did you see a slide show on the Home page, or a bunch of images one on top of the other?

    The slide show issue in Firefox can be resolved by enabling JavaScript in the Firefox Preferences/Content pane. Would you know what the default setting is for JavaScript in Firefox? Thanks.

    Signature

    mrmwebmax (formerly mrmgraphics)
    Max out your site! mrmwebmax.com

         
  • Posted: 09 August 2012 01:36 PM #3

    Right under “Welcome to mrmwebmax,llc”? It is playing a slideshow that fades between images every few seconds.

    By default JavaScript is enabled in Firefox, and IMHO should be left on. There are too many things that will break by having it off.

         
  • Avatar

    Posted: 09 August 2012 01:50 PM #4

    +

    David,

    Thanks. That’s exactly what you should have seen. For whatever reason, my JavaScript was off in Firefox. Not sure why, as I seldom use it, except for testing. If its on by default I should be OK then.

    Signature

    mrmwebmax (formerly mrmgraphics)
    Max out your site! mrmwebmax.com