Need Twitter solution (good OSX client that supports Tweet Marker)

  • Avatar

    Posted: 24 September 2012 03:42 PM

    TL;DR: Any good TweetMarker-capable OSX Twitter clients?

    For now, I use Echofon on my iPhone and my various Macs (all running Lion, btw). The problem is, I don’t like the Echofon client on the phone. It’s limited. I prefer Tweetbot. The only reason why I stick with Echofon is that it will sync with Echofon on the Mac.

    Recently, I gave up on Echofon on iOS and the syncing, and started using Tweetbot. But of course I give up on syncing. Any suggestions for a good OSX client that supports Tweet Marker?

         
  • Avatar

    Posted: 24 September 2012 04:21 PM #1

    mlvezie - 24 September 2012 03:42 PM

    TL;DR: Any good TweetMarker-capable OSX Twitter clients?

    I haven’t found one. There was Tweetbot for Mac in Alpha, but that’s now unavailable until it’s released. And even that one wasn’t all that great, but it did support TweetMarker.

    If you look on TweetMarker’s website, you’ll see a list of compatible apps, and there are 4 that are listed as Mac apps: Twitterific, Syrinx, YoruFukurou and Osfoora.

    Time to pick your poison, I suppose.

    Signature

    -Dave Hamilton / The Mac Observer / Mac Geek Gab / Dave on Twitter
    When you find a big kettle of crazy, it’s best not to stir it.

         
  • Avatar

    Posted: 25 September 2012 01:28 PM #2

    Dave Hamilton - 24 September 2012 04:21 PM
    mlvezie - 24 September 2012 03:42 PM

    TL;DR: Any good TweetMarker-capable OSX Twitter clients?

    I haven’t found one. There was Tweetbot for Mac in Alpha, but that’s now unavailable until it’s released. And even that one wasn’t all that great, but it did support TweetMarker.

    If you look on TweetMarker’s website, you’ll see a list of compatible apps, and there are 4 that are listed as Mac apps: Twitterific, Syrinx, YoruFukurou and Osfoora.

    Time to pick your poison, I suppose.

    *gulp*...

    Trying Twitterific, and it seems to work. But the marker usage is unclear. YourFukurou doesn’t seem to want to behave with my firewall, and Syrinx doesn’t seem to have been updated since 2010?

    I’ve heard disappointing things about Osfoora. Anyone had any experience with it before I drop $5?

     

         
  • Posted: 24 October 2012 04:18 PM #3

    I own and have liked Twitterrific and Osfoora. However Tweetbot for Mac just came out so I switched to that. And since I’m using Tweetbot on Mac, iPhone and iPad, I have switched over to iCloud sync instead of Tweet Marker. So far that has been working well.

         
  • Avatar

    Posted: 24 October 2012 04:50 PM #4

    David Nelson - 24 October 2012 04:18 PM

    I own and have liked Twitterrific and Osfoora. However Tweetbot for Mac just came out so I switched to that. And since I’m using Tweetbot on Mac, iPhone and iPad, I have switched over to iCloud sync instead of Tweet Marker. So far that has been working well.

    I love Tweetbot on iOS, so when it was released for Mac, I bought it right away. However, I’m considering going back to Twitteriffic (at least until an update). I don’t know if it’s because I’m behind a proxy firewall or what, but it seems to ignore TweetMarker. I haven’t tried iCloud yet (I can’t use it with all my devices yet), but am curious if syncing last-read markers works between iOS Tweetbot and OSX Tweetbot.

         
  • Posted: 24 October 2012 05:17 PM #5

    It does. Or did. Sort of. Lately (maybe the last month or so) I had a terrible time with Tweet Marker. I’ve used all my clients that support it and maybe half the time it would work, half the time it wouldn’t.  They’d scroll to the wrong spot, or not show a marker at all. Very frustrating.

    I tried all my apps: Twitterrific for iOS and Mac, Tweetbot for iOS and Mac (beta at the time), Twittelator Neue for iPhone, and Osfoora for Mac. I couldn’t get a reliable sync from any combination or permutation.

    [ Edited: 24 October 2012 05:54 PM by David Nelson ]      
  • Avatar

    Posted: 24 October 2012 05:51 PM #6

    I have a laptop at home running (at the moment) 10.7.2 (and thus isn’t running Tweetbot which requires 10.7.4 (and yes, why not just upgrade—well, let’s just say it’s complicated)). It has Twitteriffic and iOS tweetbot syncs with that just fine via TweetMarker.