Forum

[Solved] Attachments might not be working properly  

  RSS

0

I tried to attach a 1.6MB png to a post but I got the error "413 Request Entity Too Large" from ngix. I also couldn't remove the attachment, so I had to refresh and repost. The file size limit says it's 10MB but looks like it's boogered (sorry to get all technical on you.)

 
0

Thanks, @podfeet. We'll take a look!

 
0

Circling back here, I believe this has been fixed (in a few different ways, including the new inline pictures in posts feature we added!), but please let me know. 😉 

 
0

For anyone else running across this "413 Request Entity Too Large" error from nginx, the fix was to add the following line to the http or server or location context in the nginx.conf file:

client_max_body_size 2M;

The client_max_body_size directive assigns the maximum accepted body size of client request, indicated by the line Content-Length in the header of request. If size is greater the given one, then the client gets the error “Request Entity Too Large” (413).

2M is 2 megabytes, so set it to whatever you want, so long as its equal-to-or-lower-than the upload_max_filesize and post_max_size set in your php.ini (or other, similar PHP config locations).

This post was modified 3 months  ago by Dave Hamilton
 
Share: