Forum

[Solved] 2018 Mac Mini: 3rd party Ram issue  

   RSS

0

I recently purchased a 2018 Mac Mini i7 with 8GB ram and also ordered 32GB 3rd party Ram from Crucial. So far only 1 stick 16GB is showing in Bank 0.

I've taken the Mini apart 2times now, once to in stall the 32GB 2 stick and once again to reset the Ram, I want to minimize the process as the WiFi antenna connector is a fragile bit.

I've reached out to my vendor for an RMA.

This topic was modified 11 months ago by bthom70
This topic was modified 11 months ago by Dave Hamilton
5 Answers
1

Update and resolution to my Ram issue.

I finally got replacement RAM from our commercial vendor (this was a work Mac Mini for me) and after putting it in the Ram still did not work and only 1 DIMM would show as 16GB. So I called Crucial and spent 1.5hr on the phone with them swapping each stick out 1 at the time, I think I ended up dissembling the Mini 8 times today and another 6 times before this phone call trying things on my own prior to the replacement RAM. I did not fully assemble the Mini with all 16 screws or attach the fragile Wifi each time. But by itself it was an arduous process with tiny screws and multiple Torx drivers.

The Crucial Tech suggested we check for updates again, What finally worked was this week Apple pushed out Mojave 10.14.2 that had some memory and timing noted footnotes. After applying that and inserting the 2 DIMMS again it finally recognized the full 32GB.

Wow, thanks for sharing this. Good to know. And glad you’ve finally got it sorted.

Now, given you’re the resident expert on 2018 Mac mini disasssembly, a question: How long does it take you to dig it apart, replace the RAM, and put it back together?

1

Dave, I'd say for 1st timers a good 15-20min maybe budget 30min, if you have all the screwdrivers at hand.. TR6, T10, T5 and finally a pair of tweezers. The tweezers are necessary to help move things around and retrieve the tiny screws if you drop one. The only step to make sure to take your time is to reassemble the wifi cable at the very end, its a round push on connector but very fragile, I found attaching the screw then trying to push the connector on worked better.

0

That sounds like the right path, @bthom70. One of those sticks is probably bad. Crucial is usually really good about this stuff and will likely get you a replacement quickly.

0

I'm having the same problem with 2 x 16GB Crucial ram but am on latest Mojave. It's only showing memory in bank 0 and bank 2 as empty. Do you know which bank is which? My next step is to try reseating the one not showing up. But I was pretty careful to seat both.

I've already been through return of 3200 MHz memory from Crucial as I couldn't get either to work. Now got 2 x 2666 MHz.

0

Sorry I don't remember which bank is which..
But I do remember the meticulous process I went through and in the end, there was some OS update that finally downloaded that fixed my issue. I think I only had 1 ram stick installed when that showed up..

Share: