Forum

Notifications
Clear all

Accessibility and Full Disk Access suddenly not available  

   RSS

0

I just upgraded the internal drive for my mid-2012 MacBook Pro to an SSD. So far, it's just wonderful, except for one thing...

Under System Preferences, the Security & Privacy pane, the Privacy tab:

This allows me to allow access to various system services to applications listed in a window to the right of the list of services.

Next to Accessibility and to Full Disk Access the applications list is blank.

Not only are the applications that used to be listed there gone, I have not found any way to add applications to these lists. Of course, these are the services I am most interested in working with.

I drag an application's icon to the window (as before) but NOTHING HAPPENS (unless the app is running, then I will get a message saying the application must quit before it can gain access--but even then, after that, NOTHING HAPPENS). This is the same whether I drag the icon to the window or select the application from the drop-down menu called up by the "+" button.

I have tried resetting the PRAM and doing a Safe Boot but to no effect.

I am not able to run my SuperDuper! backup on my new SSD because I can find no way to give it the Full Disk Access it requires (and that I very dearly want it to have).

Apple's Support articles about this make no reference to the possibility of this problem. I'm out of ideas.

Please help!

2 Answers
0

You didn’t say what version of macOS you are running. 

I had a somewhat similar issue where FileVault would not turn on after I replaced my hd with an SSD. Turns out that the process I had originally used to clone the hd did not preserve the special extra partition on the original hd that Apple uses for some security features. Without this blessed partition, hardware security just wouldn’t work. 

I ultimately had to update superduper and re-clone the hd to the SSD again. This time the extra partition came across correctly. After which, the security stuff worked correctly. 

@cpragman
Thanks!
I'm still on Mojave since I have been fighting with this since I first upgraded and this encouraged me to upgrade to the SSD in the first place.
I used Carbon Copy Cloner since the copy I made with TechTool Plus wasn't bootable.
I'll try this again.

0

OK, I redid the copy (with Carbon Copy Cloner) from my old drive to the new SSD, this time after booting from a USB flash drive so that neither the source or target were the 'startup drive' (should have done this the first time -- but I didn't; I got caught).

Seems to be all better now.

Of course I lost all the program updates and upgrades I did after first booting under the SSD yesterday...whatev's.

Thanks so much for the help! I was just too eager to pay close enough attention to what I was actually doing.

Share: