Forum

[Solved] "Add to Safari Reading List" from third-party apps broken  

  RSS

0

I recently decided to use Safari Reading List as my read later service, which I have done in the past quite successfully. I noticed, however, that pages I was adding from Reeder on the Mac were not making it to the Reading List. It's all working fine from iOS devices. 

I tried some other third-party apps and they also failed to send pages to the Reading List, although notifications indicate that they think they have succeeded.

I've tried restarting the apps, restarting Safari, restarting Mojave, etc. Nothing works. I don't see any settings that would affect this behavior. I've tried shutting down any browser extensions that might have an effect? No joy.

Any ideas? For now I'm working around by adding the pages from Safari itself.

 
0

Interesting. Is this happening consistently with all your macOS devices? Or just one?

And if you use Reeder on iOS, does that successfully add to your Reading List?

And, while we're here 🙂 does your Reading List properly sync once you're able to actually add something to it?

This post was modified 1 month ago by Dave Hamilton
 
0

This issue is only on the Mac. A 2016 MacBook Pro running Mojave. All third-party apps seem to be affected, so it must be on the Safari side of the equation.

Works fine on iOS.

 
1

Yeah, I just tested this and am seeing it, too. Using Reeder for Mac I can't add to Reading List. Exact same experience you described: it "appears" to work inside Reeder, but nothing ever happens. 

I even tried clearing my Reading List (I don't use it, and it had gotten cluttered anyway) and... nada.

As an aside, you can clear your Reading List on the Mac by opening up the sidebar in Safari at View > Show Reading List Sidebar, then right click on an item and choose Clear All Items.

 
1

My workaround now is the click on the item in the Reeder list, then drag the headline to Safari Reading list. Kind of clunky, but it's something.

 
1

I have also discovered that it works if "Add to Reading List" is invoked in Services instead of the Share Sheet. At least that saves me opening Safari for dragging. I don't know if that is a clue to the trouble or not.

 
0

@rmcrob That makes sense. It seems whatever Framework/method Reeder is using is no longer recognized by macOS, but the Services are, of course.

 
Share: