Forum

Apple Mail keeps forgetting SMTP settings  

   RSS

0

Hey MGG folks,

Apple Mail on Mojave has developed an annoying habit of repeatedly asking me to confirm the SMTP server for mail I'm sending - be it my iCloud address or my Gmail/GSuite address.

For Gmail, it insists on resetting the SMTP settings to "Automatically manage connection settings" — with no password required. However, I have this defined in Mail Preferences exactly the opposite (see screenshot).

So whenever I start Mail and send something from that address, it gets an authentication error from the Gmail server and asks me to select an SMTP server from my list of defined servers. I then need to select that server and reset the settings to what I want.

Does anyone know why Mail keeps doing this, and how I stop it from messing with settings? 

One theory I had is that these settings are shared amongst different machines via iCloud. But when I go there and check in System Preferences/iCloud/iCloud Drive (options)/Mail - this is deselected. Puzzling!

The problem also seems to happening with my iCloud address, although in this case it just forgets the IMAP/SMTP server and asks me select one from the list. Annoying!

Thanks,
Tim

Image 5 8 19 at 08.29

3 Answers
1

Following up... I may have fixed this by deleting a spurious SMTP server setup in the "SMTP servers" dialog. Not sure how these various entries…

1. Accounts/Server Settings/Outgoing Email Account
and
2. Accounts/Server Settings/Outgoing Email Account/Edit SMTP Server List...

…interact with each other. But it's a weird UX, that's for sure.

Tim

1

Keep us posted, @timcox. It might well be a related keychain issue, too. I've been seeing those creep up from time-to-time now, too.

1

Thanks @davehamilton — I think I can trace this back to the Gmail/Gsuite authentication mess-up with the last OS update. At that time, I created a new ID for Gmail in the Internet Accounts sys pref, and with that a new SMTP server set up in Apple Mail.

Then, when Apple (or Google) fixed that, I may not have deleted that account and started from scratch. Anyway, I think there was a conflict between these 2 SMTP setups.

Or maybe it was the Lunar Cycle. Who knows... 

Share: