Forum

Notifications
Clear all

Bluetooth microphone defaults back to SCO  

   RSS

0

So lately I've been trying to use my bluetooth headphones (Senneheiser 4.50 BTNC) for audio input and output, but this always results in my codec switching back to SCO (even though my headphones support APTX). I'm aware that you can fix the audio issue by switching back to the computer mic, but I haven't found any solution that allows me to continue using my headphone mic.

I've tried using bluetooth explorer to force APTX and using terminal to set APTX on and SCO off, but it always ends up defaulting back to SCO when I use the bluetooth mic. Anyone know a solution to this?

2 Answers
1

Seems that Bluetooth doesn't support AptX (or any other "high quality" codec) when a microphone is in use. I think it has to do with the fact that Bluetooth's bandwidth is limited, and the bidirectional nature of having both channels open means bandwidth has to be carved up a little differently. https://www.howtogeek.com/354321/why-bluetooth-headsets-are-terrible-on-windows-pcs/ has some notes on this.

0

My MacBook Pro (2017) supports Bluetooth 4.2, and my headphones switch to SCO for conversations. MacBook Pros got Bluetooth 5.0 in 2018.

I'm considering a USB dongle for BT5.0, like the Avantree DG60 or 1Mii B10, which both claim aptX HD support. Hopefully I'll get native support in Preferences (both Bluetooth and Sound) and Bluetooth Explorer and Audio MIDI Setup.

Share: