Clear all

[Solved] creating bootable installer on a thumb drive failed


Topic starter

I am in the process of upgrading my late 2013 27" iMac from High Sierra to Mojave. I am trying to follow Dave and John's advice by creating a bootable copy of my HD using Carbon Copy Cloner as well as making a bootable installer thumb drive.

I successfully created the bootable copy of my HD. However my attempt to  create a bootable installer thumb drive using a terminal command failed.

I downloaded the High Sierra installer from the Mac App Store and followed the instructions on this page on How to Create a Bootable Installer for macOS.

After entering the recommended terminal command a message came back that the " does not appear to be a valid OS installer application"

I entered the following command:

sudo /Applications/Install\ macOS\ High\ --volume /Volumes/thumbs --application /Applications/Install\ macOS\ High\

I received the following response telling me the installer is not a valid application:

/Applications/Install macOS High does not appear to be a valid OS installer application.

Where have I gone wrong? How can an application downloaded directly from Apple be not valid? 

Topic Tags
2 Answers

From what you've pasted you have a typo in the last part where the parameter should be "applicationpath" not "application". Eg.

sudo /Applications/Install\ macOS\ High\ --volume /Volumes/Untitled --applicationpath /Applications/Install\ macOS\ High\

I always refer to the Macworld site as they issue updated instructions each year for this task including links to apps that will do it for you from a GUI interface:

Thanks Graham 🙂

Topic starter

Just tried it again with terminal and with one of those GUI apps (Install Disk Creator) and I am getting the same error message that the installer downloaded from Apple is not valid:

The selected item does not appear to be a valid macOS Installer.

It is lacking the file "Contents/SharedSupport/InstallESD.dmg"

Any ideas?

What is the overall size of the "Install macOS High Sierra" app on your Mac? It should be at least 4GB, probably more, in size. Sounds like you need to download the installer again, if possible, through the App Store.

There are circumstances where the Mac App Store determines there isn't enough space on your hard drive to initially download the full installer so instead creates an app that will do the real download at install time and try to free up temporary space to allow that. It sounds to me like the installer you have might be an instance of that.