Forum

Notifications

Cryptic AHT error code - 4HDD/11/40000004:SATA(3,0)  

   RSS

0

I'm having crashing problems with my Mac Pro 3,1. While doing various trouble shooting stuff, I found the old install disk & have run the AHT a few times with differing drives in the bays but I get the same error each of the times I have run it. The advanced test takes like 6-7 hours.

This is the error:

4HDD/11/40000004:SATA(3,0)

It appears from various google searches that it refers to a bad hard drive, but usually in most of the info I can pull up the end of the error is SATA(0,0) & the discussions are mostly about single drive machines. Does anyone know if the SATA(3,0) is referencing a specific bay? 

I did have a drive that I used for time machine in bay 2 that showed bad blocks which I have removed from the machine. The boot SSD in the accelsior S PCI card also showed bad blocks but only in Disk Warrior & CCC not disk utility. I'm sending that drive back to OWC since it is still under warranty. Although now that I did a secure erase(writing zeros) the error message is no longer showing up.

I'm currently testing the RAM with rember with just the PCI card in with a different SSD drive for the OS. I had 44gb of ram, but right now I'm just testing the last two owc purchases which are two pairs of 8gb sticks.

As you would guess, I run old computers. The mac pro 3,1 is actually the main work station in our little mom & pop graphic design firm. It was running snow leopard while this was happening, although it had a test mountain lion drive also. I received a much more powerful "new to me" graphics card that I was planning on adding into the machine but it requires mountain lion to run. I'm currently running the mountain lion OS wondering if this is a software issue opposed to hardware. I've dropped the new graphics card into the machine to make sure the old stock card is not the problem & the machine has bombed with the new card in also. I have been going nuts trying to figure this out.

I have a sick feeling that the mountain lion install is tainted because at one point I did migrate over my wife's snow leopard user account. I'm pretty sure the machine had bombed already with the untainted mountain lion OS. I have done so many different combinations of stuff right now I'm forgetting specifics.  

2 Answers
0

The error code appears to suggest a hard drive failure. My own searches for the error suggest this possibility.

If you don't have a backup, boot the machine from an external drive or set it to Target Disk Mode to facilitate a data transfer before the affected drive dies catastrophically.

After a backup you can be at ease with any other resolution steps you might be considering, first secure your data to another drive. You can then try disk utility or some other 3rd party drive repair utility.

This post was modified 1 month ago 3 times by Alex Santos

@alex-santos

Thanks for commenting. Luckily I had both a clone & a time machine back up of the main hard drive. Even though I was getting bad block errors from both the main drive & the time machine drive I was able to make additional time machine & clones of the drive. IT's nice to have four bays & a PCI card with an SSD available. I'm currently tracking down the error as i have been able to run AHT without getting the error with all of the drives out. I've been concerned that it was a bus problem, but now I think I may have had several bad drives or possibly some of the newer drives are 6g vs 3g. Not sure yet but I just found a comment about 6g drives having data corruption when used on a 3g bus.

The strangest thing was that CCC showed a el capitan recovery disk on my snow leopard drive. I'm wondering if the bad blocks were actually just the AHT that's 10.5 not understanding the newer recovery disk & calling it bad blocks.

0

You did well to remove the drives and test. You effectively isolated the issue using a probing question — is it the drives?

I am not sure of all the steps you took but you can run AHT with just one suspect drive to learn if the error reproduces itself. If so put that drive in one 'pile', then move on to the next drive, unless AHT identifies each drive.

The good thing is that your troubleshooting probed the issue down to the drives and not to the computer's buses.

If applicable you could consider testing the affected or suspect drives with known working SATA cables. It could be a cable. Just a thought that might help save an otherwise good drive but then again other drives did not reproduce the error when using what I suspect were the same cables, so I doubt cables are faulty.

Update us if necessary.

This post was modified 1 month ago by Alex Santos
Share: