Forum

Disabling S/MIME in Apple Mail  

   RSS

0

I'm working with someone who uses a G Suite account with Apple Mail. A prior tech had set up S/MIME for her so she could encrypt outgoing messages (this was way beyond the needs for her use case), and now she is getting certificate errors in Mail. I heard in a former episode that S/MIME is not going to be supported any longer? Beyond that she doesn't need it. Any way to simply disable S/MIME for her? Do I need to delete the certs in the keychain?

Screen Shot 2019 06 24 at 8.58.23 AM
Screen Shot 2019 06 24 at 8.59.22 AM

2 Answers
0

That particular certificate is self signed and so it won’t be trusted until it is manually marked as a trusted certificate.

As @johnfbraun has mentioned, deleting any personal certificates, including expired ones, that have previously been used to encrypt *incoming* messages will result in those messages becoming unreadable. So best to keep them.

Mail provides the icons/buttons for deciding to sign (sender’s certificate) and/or encrypt (recipient’s certificate) so by setting the signing icon off will stop the addition of the sender’s self signed S/MIME attachment.

@kiwigraham thanks for your reply. This is her reply: "On emails that don’t send, I click the ‘details’ and trust-always trust. Then they send, but the next email has the same problem.
So I guess either circumvent the signing certificate or set it permanently."

0

Now that I'm back at my Mac, here's a screenshot of the icons for encrypting & signing. She needs to deactivate the signing one, as indicated, which should stop mail from trying to use her certificate on outgoing messages.

Screen Shot 2019 06 26 at 09.32.54

Share: