Forum

Drive mounting weirdness  

   RSS

0

And yet another frustrating oddity....

My iMac and my wife's iMac share the same network (each connected via Ethernet). All seems fine in general. My wife's computer shows up in the Locations section of the Finder sidebar on my Mac. Also good.

However, when I select to connect to her iMac from mine, the connection succeeds but the hard drive itself does not mount (only the external drive connected to her iMac mounts). This started happening only after updating to Mojave.

Oddly, we can do the reverse with no issue. That is, my iMac's drive will correctly mount on her iMac.

Any ideas how to fix this?

3 Answers
0

I am guessing (I don’t have Mojave as my iMac is too old) but is it to do with needing to grant full disk access on the machine with Mojave to the daemon used to serve to the other Mac. In this case file sharing? 

0

Interesting scenario, @tedlandau. Have you tried logging in with her account there (i.e. an admin account)? Generally speaking, the boot drive is only accessible to be shared to admin accounts, so perhaps permissions are your issue?

I don't think that's it. I log in to my wife's iMac from my computer using my wife's name and password. Still no go. Again, all was fine until we updated to Mojave.

I was afraid of that. Very strange. What happens if you try to use the Finder's Go > Connect To Server and, in the dialog, put:

smb://ip.of.wifes.imac/Disk Name

It's OK to have spaces in "Disk Name" in this dialog, by the way.

0

No go. It refuses to connect — gives an error message about server not found. I can connect using afp:// but that leads to the same issue: internal hard drive not listed.

Share: