Clear all

Function keys inoperable using magic keyboard w/2017 MBP in clamshell mode


Topic starter

MBP 2017.. 15 inch w/touchbar in clamshell mode.  I'm using a full sized magic keyboard as my keyboard.

Even though I have "Use F1, F2, etc. keys as standard function keys" checked in Keyboard Preferences... when I hit a function key, only the "special features" work. (F10 is mute, not F10). When the keyboard viewer is opened, pressing on a function key does nothing. I can click on the function key on the keyboard viewer and yes, the function key "works" then. I'm guessing that this is some sort of disconnect between the fact that the preferences are setup for a laptop keyboard... but can't seem to find the answer.  Being that there is no Fn key on the Magic Keyboard (like there is on the laptop keyboard) I feel it's related to that. (Directly or indirectly)

Perhaps there is a workaround with Keyboard Maestro. On second thought -- I don't think Keyboard Maestro is the answer unless I want to change the key commands I already use.  I've been a professional Logic user since 2002 (oh, Emagic) Seems I should be able to use as standard as a keypress as option-F9 in this setup without too much headache.... right?  If I hit the function key on the keyboard, as I mentioned before... it doesn't even register on the keyboard viewer app.  This feels like a system level issue...

Any insights would be greatly appreciated.

Forgot to mention... I'm rocking Mojave on this computer at the moment.

4 Answers

Is this option for "external" keyboards selected in System Preferences -> Keyboards?


Oooh. I'm not seeing anything that mentions "external keyboards" there, but the option you have an image of there is checked.


the wording is different. it says "when this option is selected, press the Fn key to use the special features printed on each key".

OK, try this screen shot. This is taken when I have an Apple Magic Keyboard paired to my Late 2016 15" Macbook Pro with Touchbar


I'm at work, and I attached an external monitor, my Bluetooth Magic Keyboard, and a mouse because when the Macbook Pro is closed, I need a pointing device.

The following is what the System Preferences -> Keyboard looks like WITH the Macbook Pro open, and it shows 'External'.

Also with both displays operational my Bluetooth Magic Keyboard function keys acted like F1, F2, etc... keys, and I had to use the fn key to get the Mac functions to work.


This screenshot is when I closed the laptop lid.  NOTE: I had to Quit System Preferences, and re-launch it so that the display would change.

And again my Bluetooth Magic Keyboard function keys acted like F1, F2, etc... and I needed to use the fn key to get the Mac functions.


No matter whether the laptop lid was closed or open, when I toggled the System Preferences to behave as F1, F2, keys or as Mac functions, the option took effect and my Bluetooth Magic Keyboard behaved as expected.


That is interesting. I wonder what's different between our two systems... I wasn't closing out of preferences before... but now when I do it, I still see no change. Regardless if the preference is selected or not, I must hit the fn key to get a function key... I'll try the test user account and get back to you.


same behavior on my test user account. Out of curiosity, does your MacBook Pro have a Touch Bar?


ahhh I just answered the question by looking closer at your images. Seems you do have a touchbar ...

man. I'm flummoxed!

Topic starter

Ok... I've made a LITTLE progress...  seems I forgot there IS a fn key on the magic keyboard.  However, regardless whether I have the option checked "Use F1, F2, etc. as.." I must hit the fn key along with the function key for it to transmit.  The option seems to have no effect whether checked or not.  Strange.  

I took the laptop out of clamshell mode.  Still acts weirdly.  Now that I think about it, it's always been this way.  Hard to explain.  

while watching the keyboard viewer:

viewer is showing US full keyboard (note, not touchbar keyboard! even though no external keyboard is connected anymore)

hold down fn - I see function keys on touchbar

while holding down, hold down another modifier (lets say command)

all good there... I see the command key pressed on the viewer

while those two held down, I press a (touchbar) function key. -- the keyboard viewer changes to the laptop keyboard w/touchpad, and only transmits the function key... not the function key with the modifier.... modifier doesn't transmit.

strange, yes?

behavior doesn't seem to change when that option is checked or not...  gonna do a restart, but wanted to post now before I did.  no news is bad news.  😉



I was NOT in claimshell mode when I took the screenshot. It was easy to attach the Bluetooth keyboard, but also attaching a monitor so I could use Claimshell mode was not possible at the moment.
Maybe tomorrow, when at work IF I THINK ABOUT IT 😀

Ahhh yes... when I'm not in clamshell mode, the option in is worded like yours with "external keyboard"

I was thinking the anomaly might have something to do with the fact that when I did that earlier test, I forgot I was still connected via bluetooth to the magic keyboard. I took my laptop home where there is no bluetooth devices connected and I'm getting the same behavior as above.

keyboard viewer pressing nothing:

pressing fn + F9 (which works, note change in keyboard style and the SHIFT key)

fn + command + F9 -- doesn't work.

shows SHIFT-F9 like before, not transmitting the command key

I am confused. again, the above behavior is using the laptop keyboard, not the magic keyboard.


Just to confirm it is Touch Bar Late 2016 15" Macbook Pro (the first model to get the Touch Bar; as well as the yuckie Butterfly keyboard 😝 )

What happens if you boot into "Safe" mode?

This will not load any 3rd party additions, it will load some more conservative Apple drivers (may cause screen flicker), and it will clear some kernel caches (a cache is saved data in a form that can speed up a program, but is totally redundant to the original source, and thus can be safely cleared).  Booting into Safe mode is just an experiment, but can frequently eliminate any 3rd party interference, or a cached item out-of-sync with the world.  (Verify Safe mode via Applications -> Utilities -> System Information -> Software -> Boot Mode -> Safe vs Normal)
This post was modified 2 years ago by datafornothinandbitsforfree