Clear all

Google Software Update Crashing  



Hi all,

For the last few days it's appeared that Google Software Update shows up in Clean My Mac as "unresponsive", then goes away. I tried deleting all of the google keystone launch agents, but it doesn't seem to help. Chrome is up to date. Anyone know how to resolve? It's a minor irritation, but I can't seem to make the little bugger go away.

3 Answers
Screen Shot 2019 04 10 at 6.03.33 PM

Here it is. It was difficult to capture because it is quickly dismissed after it shows up. 


I'm seeing the identical behavior for the same amount of time. If anyone knows about this to fix this, it would be great.

I have had the same problem - over and over. I opened Chrome and checked if it needed updating - it didn't. ... but the problems stopped, so far. To be clear - I just opened Chrome, went to About, watched the software check for updates, got an all clear, closed Chrome.

Ooh, the plot thickens! I went to Software Update as you suggested and got this:

Update failed (error: 12)

Error details:
Found non-functional system update engine. Please reinstall Google Software Update from
KSUpdateEngine no ticket to update for the specified product ID.
Learn more
Version 73.0.3683.103 (Official Build) (64-bit)


I wonder if simply removing Google's Auto-Updater and letting it reinstall itself (presumably via a Chrome launch or whatever) would resolve this?

@davehamilton how to remove the auto-updater though?

I haven't tried this in a while, but I know both @johnfbraun and John Martellaro have mentioned this in the past: