Forum

how to deal with "Not authorized to send apple events to finder" error when running scripts?  

   RSS

0

hey guys, I running into an error which I can't get around. I'm running InDesign CC 2014 on Mojave (we need this older version because of a plugin available only for that version), when I run a script I made that has to create a file on the desktop, I get the error mentioned in the title. Usually, the system will bring a dialog box asking if I want to allow that app to have access to the Finder and if I click allow, everything should be good, BUT, I don't get that dialog for ID CC 2014. I did get it for CC 2019, and I can see CC 2019 in the security system prefs but not CC 2014. I know that Adobe decided to use a weird way to identify there app under mac OS because you can't tell an ID CC 2014 file to open in CC 2014 and a 2019 file to open in that version. It's like the system is only considering the last version for the security feature. I've tried to drag ID CC 2014 in the Full disk access, but when I do that, it puts CC 2019 instead. I've also tried to reset the command line AppleEvents, but still no joy. This is really annoying since we have to run a bunch of script and get this error message each time. The work around is to run those scripts from Script Editor, but this is really annoying. I know some of you work with scripting or help other folks that might have fallen prey to that error using automation on their mac, so I'm hoping someone has a suggestion.

TIA!

1 Answer
0

Usually these things are listed in System Preferences > Security & Privacy > Privacy > Automation. Is something there unchecked for this script?

macOS Automation Permissions

Dave, that's what I'm saying, it would normally be there, but I only get ID CC 2019, not CC 2014 in that panel. And there is no way to add one manually, but since I don't get the dialog box asking for permission, well, I'm stuck.

Share: