Clear all

iMac doesn't shut down, and other problems...  


Topic starter

For quite some time my iMac (late 2015, core i7, 1TB SSD, 16 GB RAM, hasn't been able to shut down.  Generally the iMac works ok and seems stable, but if it needs to restart or shutdown (and normally it stays on 24/7) the applications quit, the screen goes black, it shows a spinning wheel and that's as far as it gets. The spinning wheel continues, doesn't freeze, but even if left overnight like this it doesn't shut down.  I have to hold down the power button to complete the process.  One possibly important fact is: if I start up the iMac, the shutdown process works fine for a while.  It seems that it's only after it's been up and running for some time (ie. the following day) that the problem arises.

I'm also having a few other issues - my Apogee One USB audio interface works fine, but the following day I get no audio from it even though the lights come on, the system can see it.  Unplugging it, restarting, or even doing an Apogee One firmware update (without unplugging it or restarting) gets it working again.  Here's the interesting part - it then works fine but typically the following day it isn't working.  ie.  just like the shutdown issue - it works fine for a while, then the problem recurs.  If nothing else, it makes troubleshooting really difficult/time consuming - because I cannot just make 1 quick change and see if it's fixed the problem.

For a long time I had issues with iTunes randomly crashing too, though that seems to have been ok for several months now.

The iMac is set not to sleep.

I've spent quite some time trying to trouble shoot these issues, but never got to the bottom of them, never felt like I've had enough time to do a nuke-and-pave.

Things I have connected to this iMac are 2 Thunderbays (via Thunderbolt 2), a Drobo 5D, an Apogee One, Apogee Gio (which works fine consistently), APC UPS.  I have Softraid running, Little Snitch (in Silent Mode), Carbon Copy Cloner doing automated backups, iMazing.

I have the standard (not sever version) of Mojave (latest updates).  I used to run the server version, but since they added the ability to have caching and Time Machine server to the main OS I no longer need it.  I have 2 MacBooks that backup to this iMac.

I've tried various troubleshooting things like SMC reset, PRAM reset, Safe Boot (which takes forever - even with no external peripherals plugged in), cleaning caches, run the built in hardware test.  Tried moving the Apogee One to a different USB port (as suggested by Apogee) and different USB cable.

Any other ideas for troubleshooting these issues?  If I nuke-and-pave am I likely to find the issue recurs because it could be a conflict with some of the hardware/software I'm using?

This topic was modified 2 years ago by Jon

Your mention of a really long safe mode start makes me wonder if you have an APFS snapshot issue. I was seeing this symptom and only found the reason when I tried to use Disk Utility to perform a repair (which took a long time before it failed). If a background process is trying to work with snapshots (Time Machine for instance) that process may similarly be getting tied up with a “non responding” snapshot. That may not be obvious until macOS asks the process to quit during shutdown, and gets no response.

I “solved” my snapshot error by cloning the volume, reformatting the drive with APFS, cloning back the startup volume.

2 Answers
Topic starter

Thanks for the suggestion.  I too wondered if it could be something to do with snapshots but unfortunately they're not something I know about.  I did noticed that Disk First Aid takes a long time - however it does seem to complete without problems (eventually).

I'd also wondered if it could be the laptops not 'closing their sessions' (if there is such a thing) with Time Machine - but not sure how I find that out.  I vaguely recall that there are terminal commands to find out what processes are preventing a disk from unmounting but I've long since forgotten.

Topic starter

An update as I "may" have found the source of these issues:

1) Failing to shut down - last week I turned off 'file sharing' and today I restarted my Mac (having been up for several days) and it restarted without issue - first time my iMac has restarted without problems having been up for more than 24 hours since I don't know when.   So file sharing  - presumably time machine - seems to be the cause.   Not sure what to do about it (other than no longer using Time MAchine server).

2). Apogee One stops working - the problem had become so severe that MainStage kept telling me it couldn't process information in time (despite having simple settings and the processor wasn't being taxed significantly) - in the end Disk First Aid found corruption - repaired the drive, reinstalled the OS over itself (both things I'd tried in recent weeks and hadn't resolved the issue) and then made a point of quitting MainStage after each use (rather than keeping it running) - went several days without any issues at all.  Then yesterday ran Epic Games Launcher - noticed it switched sound output from the One to the internal speakers, I later used MainStage switched sound to the One - and it wasn't working.  There have been lot's of complaints about sound issues with Fortnight (which is run through the Epic Games Launcher) - so it 'might' be that Epic Games Launcher is the issue.  What I'm not sure about is whether it installs something that might perpetuate the issue - as I was having issues in recent weeks/months despite rarely running that.  Perhaps the OS reinstall removed something that Epic Games launcher had installed, and running it yesterday has messed something up again.