Forum

[Solved] iMac hangs on reboot  

   RSS

0

I have a 2017 iMac 5k running Mojave. Just this afternoon, I restarted the computer because of some weirdness in Adobe Audition. After restart, the Apple logo came up, the progress bar filled and then the screen went to black and stayed that way. I tried resetting the NVRAM by unplugging the computer, letting it sit for 15 seconds, and then plugging back in. No good. I disconnected everything from the iMac except the keyboard. No good. I tried Recovery mode, which worked, and ran Disk First Aid. It found some errors but then said the disk was okay. I quit DFA and went into Startup Disk, but when I tried to select the Clone drive I'd just attached, I got an error message about not being able to change drives and I couldn't get out of Startup Disk. I had to reboot, but was back where I was. So I tried Safe Boot. I held down the Shift key all the way through the opening progress bar. Eventually a spinner came up and I held the shift key for what must have been at least 30 minutes, but never got the boot screen. An hour later and it's still in the same place it was with the spinner.

Any ideas?

3 Answers
0

It looks like that's what it took. I had to boot into Time Machine, wipe the drive clean, install a fresh Mojave, boot into it, then run Migration Assistant to bring all my stuff over. A Time Machine restore from the Time Machine drive wasn't enough. It had to be from scratch, which tells me that something in the System was propagated to the backups and was preventing bootup from both the internal drive and the clone. Now I have to restore all my security-related preferences that got wiped, but I'm essentially back in business 24 hours later.

0

Just checking, but you held the Shift key before the Apple Logo appeared

Yes, I did. I also did a restore from TIme Machine backup and it still won't boot afterward.

0

Did you add any 3rd party RAM?  If so, try removing it and using ONLY the Apple supplied RAM.

When you tried the clone, did you boot holding the 'Option' key so you could choose the boot disk?

Otherwise, I think it you may need to make a Genius Bar appointment at your local Apple Store.

I was able to boot into the Time Machine backup. Restoring from the backup didn't work so I wiped the drive and installed a clean copy of the OS. That did boot up. Now I'm trying to restore from Time Machine using Migration Assistant. If that brings the problem back, I'll have to go back to the wiped drive and rebuild from scratch without migrating.

Share: