Forum

Insecure Update Error! popup  

  RSS

0

Ever since updating to Mojave, I've been getting a popup error message.  It seems to happen approximately once a week or so, while using Safari.  It's the same error message discussed here:

https://discussions.apple.com/thread/7477406

The only extensions I have are UTM Stripper and Wipr.  Both were installed pre-Mojave, and I do not recall having this issue before Mojave.  I tried checking Console logs, but I can't seem to find any mention of it, and the only mention of Sparkle is its own update log, which only contains two brief lines.  Also, the popup shows a generic folder icon, rather than the specific app or extension causing the error, so I have no idea what's causing the problem - I don't even know for sure it's specifically linked to Safari or one of its extensions, since it's usually running all the time.  Consulting Sparkle's docs didn't help me (I think it's a little over my head).  UTM Stripper appears to be a dead project as of over a year ago, and will no longer work after the next macOS update, so I don't know if creating a GitHub account to contact the dev will do any good either, assuming that's where the problem lies.

Anyone have any idea what I can do to find and hopefully fix the problem, aside from not using Safari anymore?

This topic was modified 3 weeks  ago by mrhooks
 
0

The Sparkle framework is used by a lot of 3rd party apps, that are external to the Mac App Store, to manage their update procedures. Safari extensions are now solely mainly(?) managed via the Mac App Store so I think you need to broaden your search to all your non App Store applications and manually check for updates. Hopefully you'd then explicitly see which one is causing the error and you can then manually download the latest version.

I'd guess at a background "helper" app - along the lines of Default Folder.

This post was modified 3 weeks  ago by Graham McKay

Thanks for the info!  That eliminates Wipr then.  UTM Stripper was installed via GitHub, so that one is still a possibility.  (It's my #1 suspect, actually.)

The last time that message appeared (earlier today), the only non-App-Store apps running were MenuMeters PrefPane and MalwareBytes Agent, and the aforementioned UTM Stripper Safari extension.  MalwareBytes is the only one with a manual update feature, and it worked without issue.  MenuMeters requires manual installation of any updates.

UPDATE: I was told that it couldn't possibly be a Safari extension.  I tried manually checking for updates with every non-App-Store app I have, and none of them reproduced the error popup.  I guess I just have to hope that, whichever app it is, the problem goes away whenever it gets updated.

2

An outgoing firewall tool like Little Snitch could help identify what it is that is trying to query the external update server. Or, if the problem can be reliably repeated, a traffic capture tool like Wireshark would also allow some analysis. If you’re not already using those it might not be worth the effort though.

 
Share: