Forum

Mac OS Mojave_Upgrade from High Sierra (5 days trying to install) Hangs  

   RSS

0

Please help me, I have projects I need to complete: Mac OS Mojave_Upgrade from High Sierra (5 days trying to install) Hangs on install. I have tried the following:

1: Download from Mac App Store and ran Mac OS Mojave Installer

2-Command + R, I have tried this

3-I tried to install from a 2008 MacBook Pro, using Target Disk Mode.

All of theses items get me to about 80 % and then it hangs, I will wait 3-8 hours and nothing, IO am forced to Force Shutdown.

When to boot up holding down Option Key,  I do not see my hard drive, it only shows 2 Mac OS Mojave Installers.

Please help me resolve this ASAP.

Thanks in Advance,

Sebastian

This topic was modified 8 months ago by Dave Hamilton
3 Answers
1

My guess is that you have somehow messed up your iMac's Harddrive which is probably a fusion drive. If that happens, you have to somehow format the drive and recreate the fusion drive. Then you'll be able to install the OS.

0

So, sounds like you've got a hard drive that has no working operating system on it at the moment??

You have mentioned trying to boot with Command-R and installing from there - what version of the operating system is it trying to install when you do that? (If the Mojave upgrade didn't complete I would expect the recovery partition to still have High Sierra). If trying to reinstall High Sierra also freezes then the problem is not specific to Mojave. You could try booting with Option-R instead and see what version of the OS that presents for reinstall (in theory it gives you the highest compatible version).

To try and work out where the freeze is happening, I'd suggest having the installer log window open during the install. I found this article that describes the key presses required for that. 

Show the Installer Log During High Sierra Installation

I'm a little surprised about being able to run the Mojave installer from a 2008 MBP but the way I would try to use an "independent" installer is by creating a USB thumb drive installer to boot the target Mac from.

This post was modified 8 months ago by Graham McKay
0

I would build an OS install disk on a USB drive and load it from that. You don't say what you are trying to install on, but if it is an iMac, I would also make sure you reset your PRAM (command-option while holding down the P & R keys), and your SMC (shut down your computer and disconnect from power for 15 seconds)

Share: