Forum

Notifications
Clear all

Mac stopped searching external drive

   RSS

0
Topic starter

2012 iMac running Catalina.  Moved home directory to LaCie 6TB Thunderbolt external drive 5-6 yrs ago with OS staying on an added internal SSD.  Been working great.   

At some point in last 6 months my machine stopped searching 6TB drive.  I can see all the files & open files on the drive.  Back it up nightly.  Backup exhibits the same behavior...can see and access files on it, just can't search it.   I have tried resetting search indexing multiple times by adding and removing drive from search privacy tab in system prefs.  I tried that process on my daily user account and admin account.  I tried reindexing using terminal commands.   

Other external drives (2- each with a similar daily backup match) are problem free.   I checked the permissions and gave user, admin and even everyone -read/write permissions. (don't tell anyone)   This 6TB drive also contains the local folder for my dropbox which houses 7-8k pdf files...can't search  them either but I am sure it is related to the drive itself.   Other machines can access and search the dropbox

Been listening as long as you have been podcasting...due to your never ending flow of tips and troubleshooting advice, this is the first time waving the virtual white flag and begging for help.

Topic Tags
3 Answers
0

Try using the mdutil command to erase and rebuild the spotlight index. 

in Terminal you’d type the following to rebuild the index for the boot drive:

 

$ sudo mdutil -E /

 

for your external drive, you’d put the path to the external drive where I put the / in the example above

@cpragman appreciate your help. I struggled with the terminal syntax but eventually got that part figured out. Problem still persists. Here is the result I got. Does this explain what is happening?

camerons-imac:~ iMacAdmin$ sudo mdutil -E /Volumes/External\ Raid\ 6TB
/System/Volumes/Data/Volumes/External Raid 6TB:
2021-10-22 0726.961 mdutil[14475:448472] mdutil disabling Spotlight: /System/Volumes/Data/Volumes/External Raid 6TB -> kMDConfigSearchLevelOff
Indexing and searching disabled.

I also tried -i on and got the same result.

0

So far so good, now use the "-i on" option to turn indexing back on for the external drive.

 

example

$sudo mdutil -i on [path to external drive]

0

Hi, I also had such an issue, my MacBook worked very well at first, but then it began to freeze and work worse. I tried to clean it, contacted even the service center, but they kept silent there, then I decided to ask my friend for help. He advised me to follow this url, I used all the recommendations in the article and the MacBook began to work better. Try it, it will maybe help you.

Share: