Forum

Notifications
Clear all

[Solved] MacBook Pro USB Port is Not Working

   RSS

0
Topic starter

Hi Everyone! My Macbook Pro's USB Port is Not Working. I tried in all ports but facing same issue. I resetted the USB port but still facing same issue.

@johniu676 Try to clean it with proper cloth and also clear all dust.

4 Answers
1

I would recommend you to reset the MVRAM. Here are basic steps of uninstalling it.

  • Make sure your MacBook is connected to a power supply.
  • Shut down your MacBook.
  • Restart Mac and immediately press and hold ‘Command’, ‘Option/Alt’, ‘P’ and ‘R’ keys together.
  • Hold the four keys for 20 seconds and release them after the second time startup sound comes on your Mac. If your MacBook has a security chip installed, then release the buttons once see the logo of Apple second time.

If you still face any problem then simply follow this link. You will get different methods for resolving your issue.

Thank you for your recommendation. Let me check it weather it helps or not.

1

Just perform few steps and your problem will be resolved

  • Clean USB ports so that if there is any dirt it should get removed.
  • Go to ‘Applications’ and choose ‘Utilities’.
  • Inside Utilities, select ‘Terminal’.

If you still face any difficulty then tell me, I will give you another solution.

0

Try an SMC reset

https://support.apple.com/en-us/HT201295

0
Topic starter

I tried this but still I am facing same issue.

Share: