Forum

Mail missing its viewer window  

Page 1 / 2 Next
  RSS

1

Started with a hard drive failure. Replaced and restored data from TimeMachine. This also represented an upgrade from Yosemite to High Sierra.  Now launching Mail. No windows appear. All menu items are grey except for Preference and Accounts under the Mail menu. Able to open Mail Preferences from menu bar. Can see that accounts (3) are online.  Nothing Mail related showing in Console.  I suppose it's updating the Mail database, but have left it running for hours, and still no sign of a window (as well as no progress bar indicating the update).  Have updated to the very latest High Sierra.

Mail account working find on iPad and iPhone, so it's not a server or account issue.

Any ideas?

Unfortunately Restarts and Logouts are tough with TeamViewer QuickSupport. I know there are other screensharing options.

I am not sure what you mean by TeamViewer, how is it related?

Anyway, I would start fresh … meaning remove everything in the ~/Library folder related to mail and park it on the desktop.

Then sign out of all email accounts from the System Preferences>Internet Accounts.

Now launch mail and report back.

1

I don’t think it’s still updating the database. That’s usually indicated by an obtrusive window and progress bar. I’m assuming you can’t bring up the Activity window, either? That’s also grayed out?

I know it sounds simple, but have you tried rebooting? This definitely seems “not normal” so I’m not convinced that leaving it for an extended period will yield any real progress.

Have rebooted and also installed the 10.13.6 update, but neither changed the behavior.  Yes, Activity is grayed.   I'm thinking it's time to move all the contents of ~/Library/Mail and see how it responds.

1

I've seen this type of behaviour from Mail on a number of occasions and it looks to me like it believes it has a dialogue sub-window open "somewhere" but which you can't find. Usually force quitting and reopening has solved this but a few other options you could try:
1) Quit then hold down the Shift key when opening Mail again - this does similar to Safari in that it tells the app to only open the default window (may, or may not, have affect on that hidden dialogue)
2) Temporarily alter the screen resolution on your Mac, or change monitor - this may prompt the app to "redraw" all the windows back into a visible area.
3) If I remember rightly one of the plist files contains info about current window positions so deleting the relevant plist file might also revert it.

Edit: 4) Also try having your Mac disconnected from any internet connection so that Mail isn't tempted to check account status/connection.

This post was modified 4 weeks  ago by Graham McKay

Re: your suggestions: 1) I did try the Shift launch, but no help.  2) I fiddled with the screen resolution, but it didn't shake anything loose.  3) Not sure which plist to target...I've done a lot of watching of Preference folders to see what changes when I launch or quit Mail.   4) Along the troubleshooting way, once I knew it wasn't an network or account issue, I took the 3 accounts offline (via the menu). It launches and quits a lot cleaner that way.    By the way, we put Spark on his Mac and it interacts fine...but my friend just wants his Apple Mail back.

1

Hello Appleseed

Please confirm if your issue is as described in this Apple Discussions Forum post, "Mail El Capitan menus greyed out after Migration Assistant", I realize that the issue is similar, with the exception of the OS, but read through it and consider applying the steps in Link Davis' response. Link Davis is a very learned and reputable participant on Apple's forums.

If you want to try a less provocative method, restart the Mac while holding the shift key, login and then restart as normal. See if that resolves the issue.

Then again, something could be corrupt in mail and the files that make up or support your messages.

  1. Quit Mail. Force quit if necessary.
  2. Back up all data before proceeding.
  3. In the Finder menu, select Go > Go to Folder and paste this in, ~/Library/Mail/V2/MailData
    A folder window will open and you will find some files with names as follows:
    Envelope Index
    PersistenceInfo.plist
  4. Move those files to the Desktop. Don't remove the folder beginning with V. 
  5. Relaunch Mail. You should be prompted to re-import messages. You may get a warning that the Mail index is damaged and that Mail has to quit. Click OK. The process of re-importing my take only a few minutes or for very large mailboxes it can take hours. 
    If it looks like it will take hours, you can reduce that wait-time by temporarily adding your home folder to the Privacy list in the Spotlight preference pane. When mail completes the import, remove the exception from Spotlight preferences. If you don't search will be mostly unavailable and you will certainly not be able to search within the Mail.app
  6. Test.
  7. If Mail now works as expected, you can delete the files you moved to the Desktop.

    If issues persist post your results.

 

 

I did this I did see the import window for a few seconds, and then back to the no window situation.  For the amount of email he has stored, I would expect the import to take a few minutes.

There must some other preference. I watched the ~/Library/Prefs and noticed four preference files changing when I launched Mail. Trashed those, and still the same behavior.

On a different Mac, I configured his three accounts and they work perfectly, but took over half an hour to download the 30,000+ messages from the server.

Regarding the Apple Discussion forums reference, I did follow the command line "repair permissions" instructions, but it didn't fix it.  I wasn't able to do the Recovery Mode suggestion because the machine is remote.   Separately I did zap the envelop index (with Onyx) and did see the "importing" dialog when I relaunched.  It spent a few seconds importing then presented me with the same menu bar but no windows.

1

Silly question perhaps, if the viewer window is not visible did you try command-0 (that's a zero) to bring it up.

yes. all the commands that are grayed out are not keyboard launchable

0

On a different Mac, I configured his three accounts and they work perfectly, but took over half an hour to download the 30,000+ messages from the server.

So we know it's not the account itself then. Trying a new user account would only identify if the OS itself is to blame which I doubt. I think there may be some mailbox corruption. The problem is identifying it, the more mailboxes the more probing needed.

The corrupt mailboxes appear to be stalling Mail during the conversion process, you can try to identify the mailboxes that Mail is choking on. To do this quit Mail, move suspect mailboxes out of ~/Library/Mail/ (to the Desktop for example), and trash any Envelope Index files you see in ~/Library/Mail/. This should cause Mail to recreate the index and import the mailboxes that remained in ~/Library/Mail/.

If this works
You can then manually import the problematic mailboxes as 'Other'.

~/ is notation for your home folder.


Start from scratch followed by manually importing mailboxes as you see fit.

Alternatively, set up Mail from scratch and manually import after the download. You didn't mention any missing emails that might have gone as a result of trying what is essentially a from scratch exercise but then again you might not have checked for omissions. Anyway, the steps below will at least allow you to use Mail again. You can then resolve importing any old mail messages that might be missing because they were 'on my Mac' after the fact as you see fit.

  1. Quit Mail.
  2. In the Finder, go to ~/Library/. Move (not copy) the entire Mail folder to the Desktop and back it up incase (please).
  3. Locate com.apple.mail.plist inside the ~/Library/Preferences/ folder and move it to the Desktop.
  4. Open Mail and set it up again from scratch. If Mail asks for an opportunity to import existing mailboxes, don’t.
  5. Patiently wait for the sync process to occur.
  6. From the Mail menu go to File > Import Mailboxes. Follow the onscreen instructions to begin importing mail from the Mail folder that’s on the Desktop. Choose to import as 'Mail for Mac OS X' and locate the .mbox folders as the import targets.

Remember ALL the old mailboxes are on the desktop (done in step 2) but leave them there until the import complete and then consider importing them in stages as per step 6. I believe one or more of the mailboxes on the desktop are corrupt or even a single message is glitched enough to halt the import in a most peculiar way.

I know that this appears rather intrusive, but the fact that import simply stalls or worse stops entirely tells me that there must be a glitch somewhere in the ~/Library/Mail/ that you may be able to isolate in stages as per step 6. I recommend you follow step 6 in stages, don't try to import everything back at once or you might not know when you bump into the corrupt items. If you import using the rule of halves it will help you to more quickly isolate in the problematic files.

The rule of halves involves considers only half of the entire material at one time. In this case it's on the desktop (the old mail folder) and importing half at one time is how you should proceed. If that half imports without issue then you continue importing the remaining half and you continue to follow this cascading approach until you encounter an unexpected result which is a tell-tale sign of what you should now consider as the potentially affected batch of file representing the cause of the issue. At that point of discovery, it is prudent to apply this rule of halves on this suspect target batch of files. You will eventually find the file(s) sourcing the original issue.


Some considerations before importing the contents of the old mail messages on the desktop

I would not do this right away. The first thing to analyze is if it appears all your message are back. If the answer is true then don't immediately trash the old message from the desktop. Leave them there until you are satisfied that nothing is missing. Only then should you import because importing may actually create duplication and with that let me introduce you to Jolly Roger. When you go there click on software and then choose to download Remove Duplicate Messages-Mail 1.3.6.zip. After unzipped you will find a readme and an AppleScript.

Below is the splash screen as it displayed when I ran the AppleScript form the Finder but the read me has a more interesting installation process outline. I tried the AppleScript, it is nothing short of genius but slow going. It also provides verbosity in the terminal window, displaying where it is at and is interactive, asking you for what you want to do, the latter you can define on start of the app. This is an extremely well designed AppleScript and built to prevent catastrophic loss of messages, that being said backup first.

Remove Duplicates Splash screen

 

I sincerely hope this helps otherwise you are welcome to chime back with indication of where things went off course and a description of that 'brick wall'

Cheers
—Alex

This post was modified 3 weeks  ago 4 times by Alex Santos

I have removed the contents of ~/Library/Mail a couple times (no help), but I could swear I didn't see a com.apple.mail.plist file in his ~/Library/Preferences folder.  For some reason, I thought High Sierra had done away with that plist, and so I didn't return to look for it.  It might be that simple -- zapping that file -- will try when I get back to it.

 

Possibly also check inside ~/Library/Containers/com.apple.mail  and its various subfolders

I'm not certain quite to what extent Mail is sandboxed. 

0

It is there. The name starts with com.apple.mail.something…

Mail plist files

This post was modified 3 weeks  ago by Alex Santos

I found com.apple.mail.plist in the Containers folder, not in Preferences (thanks Graham!). Tried trashing that specific plist file (no change), the contents of the Data folder (within Containers/com.apple.mail (no change).  And deleting these container prefs at the same time deleting the contents of ~/Library//Mail, but no difference.  Also I'm noticing that in that Containers/com.apple.mail/Data/Library/Preferences folder, there are too security preferences that are abandoned aliases. When I delete them, they return. But checking on another Mac, this seems to be happening there too. However I did notice perhaps a big clue.  

Any changes in Mail> Preferences do not stick! So I'm thinking permissions. The files and folders in question all of proper read/write access. (I checked on another High Sierra machine that's working properly to compare).  I have run the special "menus greyed out" suggestion references above (a terminal script and corrects user permissions), which fixed this problem for someone using El Capitan.   

I found another thread which points to com.apple.universalaccess.com being culprit here. Go rid of it. No change.

Besides com.apple.mail.plist and com.apple.mail-shared.plist in Preferences, and the PersistanceInfo.plist in ~/Library/Mail, what else could be "stuck" that would prevent mail preferences from saving?

Or it could be a CoreData problem.  I notice in Console, when I launch Mail, it's seeing this error message: "error: CoreData: error: Row (pk = 93056) for entity 'ABCDMailRecent' is missing mandatory text data for property 'uniqueId' " repeated about 50 times with different row numbers.   How does one repair core data problems?

pic 2018 09 08 at 2.51.02 PM

 

"

I meant to mention in the last update that inside that Containers/com.apple.mail folder, I found the Save Application Data folder. I thought.....this must be the culprit!!  But trashing the contents did not fix the problem. 🙁 

pic 2018 09 08 at 2.13.14 PM

Page 1 / 2 Next
Share: