Forum

Notifications
Clear all

Messages app glitch  

   RSS

0

Recently updated iOS and now the Messages app is glitchy. when I try to open it a dialog box opens. I close the app and try to reopen but I get the same error message

Screenshot 2020 06 09 09.25.49

 

6 Answers
0

Ah, this is subsequent to updating macOS, not iOS. Have you tried restarting your computer? If so, can you try restarting in Safe Mode by holding Shift at startup and see if the issue is still present. If it's resolved, restart normally and see if all is well.

@earthsaver
Well, I tried it. Restarted in safe mode and had the same error message.
What else could it be?

Are you able to access Messages preferences when this dialog is on the screen? If so, sign out of iMessage, restart Messages, and then sign in again. Or, follow this more through reset if necessary. https://www.fireebok.com/resource/an-internal-messages-error-occurred-in-messages-on-macos.html

@earthsaver
Unfortunately I am not able to access preferences in messages.

0

Hi @earthsaver

The link provided by Ben Rosenthal has steps that mitigate your inability to go to Messages>Preferences. Did you follow all the steps?

Please keep us updated so that we can help you resolve the issue.

Kind regards

—Alex

This post was modified 3 weeks ago by Alex Santos
0

I tried to follow the steps in the link but I can't access Messages preferences. I signed in and out of iCloud. When I look at the path suggested, to delete files, I do not see the files shown in the link.

Screen Shot 2020 06 10 at 5.01.10 PM

 

This is not the correct Library folder. The instructions indicated you need to go to the Library in your Home folder. If it's hidden hold Option and choose Library from the Go menu. Then navigate.

0

If you are having trouble finding the correct folder try the following method from the Finder.

From the Finder visit the Go menu and choose "Go To Folder …"

image

In the resulting sheet that slides out enter the following:

~/Library/

The ~ (tilde character) denotes your home folder where a Library folder exists. Normally this folder is invisible but using the method outlined will allow you to view the contents of the ~/Library folder.

image

Otherwise, as Ben indicated, go to the Finder and hold down the Option key (alt on some keyboards) continuosly while visiting the Finder's Go menu. Pressing the option key while displaying the drop down menu will trigger the Library Folder to appear from the Go menu as a menu item. Without this key held down the Library folder will not appear in the menu. 

I made a video for you. As you will notice the Library folder appears and disappears as a result of pressing and depressing the option key.

I apologize for the extremely dark image. I will have to investigate why the video is so dark, it may be due to having multiple displays running off the iMac.

Alt key reveals the hidden Library folder

 

A bit of history (not required reading):

You might be wondering why Apple even bothered with all the fuss of making the Library folder not straightforwardly available. Well back in Mac OS X version 10.4, perhaps 10.5 and earlier the ~/Library folder was listed from the Go menu and available without any special keyboard shortcut but Apple found out that this got a lot of folks in trouble. Mac users ended up going to the said folder and felt that they could do whatever they wanted with those files and that was not the case then as it is today so Apple made it a little more tricky to get to which helped Mac users not accidentally cause abnormal behavior. 

The user Library folder (~/Library) does contain a lot of content that isn't created by the user directly but instead are there as a result of the user's interaction with various apps, using websites and email and even apps themselves will create files and directories as a course of their operation and there is a whole lot more in there. There is so much more it stores and you should not go in there and start deleting or moving things unless you know what you are doing. From time to time, as in your case, going in there and manually interacting with the right files may resolve certain issues. with that …   

 

Kind regards, I hope it helps you. Do keep us posted!
—Alex

This post was modified 3 weeks ago 4 times by Alex Santos
0

Adding the "~" worked! I was able to move the files to desktop, reboot and now messages works!! Yay!! Thank you all so much. It's a little thing but it makes my day just a little bit better

🙂

 

This post was modified 3 weeks ago by Lisa Atkinson
0

Hi Lisa

There is nothing more rewarding than receiving a message like yours. I am so delighted that your issue is resolved. Thank you all for the team work!

If there is anything else you ever need help with I encourage you to reach out to us anytime.

Have a beautiful day!

Kind regards

—Alex

This post was modified 3 weeks ago 2 times by Alex Santos
Share: