Forum

[Solved] Messages on Mac: Search Shows Only Older Threads & Beachballing Consistently  

   RSS

0

Hi all,

I have a  couple of very weird issues I'm working on here with Messages on Mac. Wondering if anyone could help.

A little history:
I started working with the customer about a year ago. He had a 2011 MBA. One issue he was having was doing a search in Messages on his Mac would not show the most up-to-date message in the respective message threads. For example: even though it was November, when we did a search for someone's name in Messages it showed the thread as it looked back in August. We tried signing out and back in to iCloud, etc., to no avail. Apple senior tech support weren't able to help either.
Fast forward to this year. When the 2018 MBP was released this summer he upgraded to that machine and we set up the machine with a clean OS (no time machine restore). We connected everything to iCloud, including Messages. No problems, everything worked fine. However just last week the issue surfaced again on the new machine, except with a vengeance. In addition to the search threads now reverting to August of this year (oddly, going back to the same month just a year later), Messages is also very slow, revving up his processor and is beachballing his system. This is odd to see for a brand new MBP with 16GB RAM and a 2.7GHz i7. I took some screenshots of Activity Monitor and the message phenomenon when my name is searched (shows August as the most recent thread with me, even though the most current thread with me should have shown late October). I again tried the complete sign out/sign in thing for iCloud & Messages again just to see if that would resolve it, but no dice. Would love to consult with anyone who has answers on this one. The customer prefers to use MacOS almost exclusively to send and receive messages, so this is a huge inconvenience and he is happy to hire someone to resolve this. I'm definitely in over my head and would love to see what you'd suggest or do for him.
I've attached screenshots of the Activity Monitor, as well as a shot of the current message thread with me along with the back-dated thread that only shows our convo from August.

Screen Shot 2018 10 31 at 10.19.34 AM
Screen Shot 2018 10 31 at 10.21.32 AM
Screen Shot 2018 10 31 at 10.17.30 AM
IMG 0550
Screen Shot 2018 10 31 at 10.25.05 AM

Thanks!
11 Answers
1

I’ve just gone back and taken a closer look at the Activity Monitor screenshots you posted and the one item that triggers a memory for me, from a client who had a beachballing Mac at startup, is mention of callservicesd and soagent. The underlying cause for my client was related to sync of contacts - not necessarily iCloud. I think we went through various logging out of services (including Google accounts) & clearing caches and reinstalling macOS. But you might find a Google search about callservicesd gives some additional ideas.

Hi Graham --

Just a follow-up. The search for soagent callservicesd led to a thread that indicated contact syncing with Google was the culprit. Thanks so much for your help. Finally solved the issue for the customer. 🙂

Best,

Ari

Great to hear, thanks for letting me know Ari. (I had incomplete notes on which of our steps definitively solved that particular issue for my client. His iMac was dreadfully slow above and beyond just that symptom/reason.)

1

Sorry, I don’t have a solution but I can confirm that the search functionality within Messages on my MBP also has frustrating search results. It can also take some time to return those results - but I don’t get the beachball. My experience is that I only see the full thread if I start a new message (by clicking on the pencil icon) and start typing the person’s name then click on the auto suggest name that is presented.

I haven’t tried remediating  this - but a guess would be that any problems with search may be related to indexing and/or caching.

1

Some other things that I looked at that might help. I don't use messages with the same level of consideration as your friend so I hope these extra tips help.

In preferences make sure these are on if you friend wants to retain all of his conversations and also turn on the sync option.

Messages Prefs
Messages Prefs 2

1

Final question for now. You say search can't find what you expect to be there. Are able to find it manually?

Please read these incase.

Change General preferences in Messages on Mac

Keep all your messages in iCloud

Save or delete text conversations in Messages on Mac

Notable for the last link:
Set how long to keep messages: Choose Messages > Preferences, click General, then click the “Keep messages” pop-up menu and choose an option.
Important: If you choose an option other than Forever, your conversations (including all attachments) are automatically removed after the specified time period is over.

This post was modified 11 months ago 2 times by Alex Santos
1

Actually I have one point I would like to make specific to beach balling. If you have only one account connected then ignore the rest of my comments.

To isolate the issue consider having only one account active for Messages as you troubleshoot. With one account connected to Messages does beach balling disappear? If the answer is true then turn on one account at a time and analyse whether the machine begin to exhibit high CPU (beach balling). Keep turning on any other accounts, one at time in an effort to analyse if any one account, like google etc, are causing the beach ball issue.

When in doubt, simplify the configuration by turning off/disconnecting/detaching as many components as you can to help you isolate an issue.

So for this case, I am suspecting other cloud accounts that might be triggering the beachballs so we switch them off to analyse if this is true or not.

1

Hi Alex,

Thanks so much for your thoughtful and in-depth reply. We created a brand new user and connected to iCloud Messages, at which point it downloads 10 years of messages from the Cloud and problem replicates. Escalated again to Apple Senior Technical Support, and they said they are going to wipe the cloud data on their end.

As always, and I think a lot of people don't practice the key step that AppleCare Tier 2 support advised, to attempt to reproduce the issue on a new user account.

I am delighted that someone at AppleCare finally was able to get the ball rolling in the right direction. Excellent news.

1

Hi all --

A quick update to this. After weeks of Apple tech support kicking the can down the road, I went back yesterday to try more in-depth measures. The customer was willing to have all of his messages wiped and not use the cloud in order to simply have a functioning Messages app in his computer -- so that's what we did. Disabled Messages in the Cloud on all devices and wiped the local Messages archive on his Mac. To our shock and dismay, however, the problem persists! I'm now at a loss. Leaning towards the total nuke and pave of his machine?? Does the fact that this problem persists after disabling Messages in the Cloud and wiping the local Messages archive mean anything to anyone?

1

Thanks so much Graham! I think we're on to something here! 🙂

1

Thanks Dave!

0

Hi Ari

I'm sorry that you are having so much trouble and I can understand the frustration. I never even used search in Messages but just tried. I searched for the word, 'it'. Search took a few seconds, I had no beach balling as described and Activity Monitor did not show the same spike in CPU. The machine I tried on is a MBA with Majove and it has 4GB of RAM and an i5.

That machine should obviously be much quicker, that being said the Activity Monitor screenshot did show other activity with high CPU usage, namely mdworker which is part of spotlight indexing so perhaps the machine was indeed being hit with a relative amount of activity but then again, mdworker is supposed to retract activity to allow user tasks priority. I am not overly concerned about CPU usage as long as it is not happening repeatedly on such a new machine.

I think your main priority right now is to find a string in your message history.

Here is what I did. Obviously, in my case the word 'it' should come up frequently and it did, roughly 250 times across 5 users. Have you tried to the combo, Command-G, after the first instance of a word was found? Command-G is used commonly across applications as a way to find the second, the third, the fourth instance, and so on, of a search term and will eventually wrap around to the beginning once it passes the last instance found.

Could you report back if Command-G is working. If nothing happens, your friend may have remapped his modifier keys via System Preferences so double check that in case.

This post was modified 11 months ago by Alex Santos
0

Contact syncing often turns out to be the root of SO MANY problems. I had an Apple Watch battery issue for a long time that was ultimately solved by wiping and restoring contacts. Curious if that’s the root here?

Share: