Forum

Network drive issue  

  RSS

0

I have a 2011 iMac and a 2017 MBP connected to my network which consist of a TC and APE w/ HDD attached. The past week or so any time I select the TC or APE in the finder it asked me for the password to connect. I click the box to remember to password but it never does. I have deleted the paaaword in Keychain and tried again but no luck, it still asked for a password every time. Next, after I connect as soon as I click on something other than the selected network drive, it disconnects. Thoughts?

I’d suggest trying a safe mode restart to clear out any cached network junk. 

Boot into Safe Mode (up to 15 minutes)

• Shut down the computer.

• Press the power button to start the Mac and immediately afterwards press and hold down the left Shift key until you see a progress bar or the Apple logo.

• Your Mac will do some cleanup steps and show a progress bar. This may take up to half an hour - let it run even if the progress bar doesn't seem to move.

• This should end up at the login screen with "Safe Mode" written in red at top right. If not, then Safe Mode didn't engage, shut down & try the procedure again.

• Login to your account (you're still in "Safe Mode" so it may look a little different including a flickering screen, don't panic!) but don't start any apps or programs.

• Leave the Mac like that for 5 minutes to "settle down".

• Shutdown and restart normally. (This restart step is important - don't forget to do it!)

• Note: This cleanup procedure deletes various "cache" files used by the operating system and apps. The next time they run they may have to recreate those cache files - so it is normal for the first restart of the Mac and the first launch of any app after a Safe Mode reset to take longer than normal.

Do you have iCloud Keychain sharing enabled?

0

Nope, no luck with that

Hmm, well it’s possible(?) that the router is disrupting network connections in some way so a cold boot (unplug from power for at least 3 minutes) might make some difference. Cold booting the TC and AX at the same time wouldn’t hurt. 

Make sure all your system drivers are installed on your computer. If it is not, then visit brother customer service to download the required drivers for the network. It can resolve all the network related issues on your system. 

 

0

Again, no dice. The HDD attached to my APX is partioned. I believe I read somewhere the APE doesn't like portioned HDD attached for some reason. Think I will reformat the drive and see if that fixes the issue, bit I doubt is as my unpartioned TC is doing the same thing. If not then believe my next step will be a "nuke and pave" of the TC and APE 😳  😤 . I hope it doesn't come to that. 

 
1

I do have iCloud Keychain sharing enabled. 

Have you tried disabling iCloud -> Keychain so that your keychain is not repopulated with out of date information from other copies of the keychain?  This would be an experiment.

0

I reset and stared new my APE (which is extending my network from my TC) with no luch resolving the issue. So wiped out my TC and APE password in Keychain and no luck. Im thinking this may be a corrupt Keychain issue.

So my next try will be turn OFF iCloud Keychain on both my Mac's and wipe out the TC and APE passwords the turn back on. Thoughts on my corrupted Keychain password theory? 

 
0

I’m definitely in agreement that this is likely a problem being perpetuated by iCloud Keychain. Turning syncing of that off might well help solve this, at least on one machine... and then hopefully you can replicate that elsewhere.

do you have iPhones or iPads also having this issue?

1st off I'm honored Dave would look at my issue. And no, the same issue is not happening on my iPhone. I did try turning iCloud Keychain on and off with no luck. On the Apple Support Community I posted my dilemma and was told this is a common issues w/ 10.12 and 10.13. I was advised to reset both my TC and APE and rebuild my network, which I will when/if I get some time this weekend.

A recent development last night was I now have my TM back ups now fixed. I had to remove the disk in the TM app then add it agin. I was prompted to connect to the server w/ my password and it connected and ran a TM back up. But still disconnected in the Finder

1

I was prompted to connect to the server w/ my password and it connected and ran a TM back up. But still disconnected in the Finder

I am suspecting wireless interference in this case, is it possible that you can place the Mac nearer to the Time Capsule (TC)? If you can position the Mac and TC nearer to each other and results are normal than you might otherwise be too far from the TC and or the materials surround the TC reduce the effectiveness of the Wi-Fi radio signal. It might also be the layout and material of your home that are reducing connectivity. Seeing the you have an AirPort Extreme as well as the Time Capsule be sure that the two of them are not too far from each other or it may contribute to a low quality signal.

If you, like me suspect wireless interference, then consider this Apple Support Article, Potential sources of Wi-Fi and Bluetooth interference.

You could also consider entering a new password for the TC, not the network password, and then updating. Also be sure the firmware is up-to-date on the AirPort Extreme and Time Capsule which you can do from the Airport Utility app.

Could you let us know how it goes but I think ruling out Wi-Fi interference due to the disconnection problem you report is a first step because without it there will a cascade of potential failure points.


Like what was recommended on Apple discussions, resetting your Airport devices is a good choice, it strips a lot of doubt away as the config would be clean. You could save the configuration for each device and then reimport after a factory default reset.

By the way, after a factory default reset, which I might recommend you consider, I would bring both the AirPort Extreme and Airport Time Capsule, and your Mac into the same room and configure them there.

This helps avoid wireless interference and in some cases keeps you from running around the house. Once the two devices are set to create a network, you can disconnect them from power and settle them back into their previous locations. This shouldn't take longer than 10 minutes to do, it's just unplug from power, bring into the same room, factory default them both, set one up and have the other extend the new wireless network (WPA2 of course), join the network from the Mac and mount your TC on the desktop which I believe you describe is contentious.

Once it's setup, return the airport's to their previous location and upon power-up the Airport routers are designed to scan their environment for other networks and choose the best channels automatically in an effort to avoid wireless interference.

Finally, the connection between the router creating the wireless network should be hardwired to the network router (your ISP network). I would not extend the wireless network of your network router using an Airport device because it is 3rd party relative to the ISP router which can cause wireless connectivity issues when it comes to extending the wireless network.

ISP Router - - - - ethernet cable - - - - Airport TC ••••• wireless •••• Airport Extreme

Please report back so we can continue to help if needed.

This post was modified 2 months  ago 5 times by Alex Santos
 
Share: