Forum

No booting. 10.15 beta 1  

   RSS

0

Hi

used the utility cleanmymac x and deleted TeamViwer Mac stopped loading. how to be?

Error:

unrecoverable error

SecurityAgent failed to create requested mechanism TeamViewerAuthPlugin:start

image

10 Answers
1

I had this same issue, and this thread helped me resolve it. My issue was that I was doing some cleanup before installing beta software (minimize the variables!) and used a 3rd party uninstaller. After I installed the beta, I wasn’t able to complete the startup / installation process because of this security error. It has to do with the enhanced security permissions that macOS is now looking for, vs previously it would just ignore the missing configuration file.

To fix it, I booted the computer with the issue to Target Disk Mode, connected to another machine via TB3 cable, and accessed the “[Macintosh HD] - Data” volume (via encryption permission prompt due to FileVault2), and navigated to the SecurityAgentPlugin folder mentioned above. As expected, there was no TeamViewer.bundle in the folder. In order to get that .bundle back in the folder (and therefore complete the boot/install), I needed to install TeamViewer on the _second_ Mac, copy the file to the first Mac, and then eject the drive/ reboot.

The machine was able to successfully boot and finish installation. I then reinstalled TeamViewer and used the built in removal tool (Menu: Preferences/Advanced) to completely remove the software.

Hope this helps someone else!

Wow, good to have full feedback from somebody with exact same problem!

@fromfargo

Hey, would you be able to help me? I have the same issue!!

0

Hmm, I haven't installed any beta but I'm sure you knew to make a bootable backup before installing it, right?

I would try to wipe the drive, and start to install the beta on a fresh drive if it's possible, I wouldn't upgrade a drive with Mojave to a beta, you'll have incompatible software like your teamviewer Plugin.

Exactly as Jeff says. I wouldn’t expect any 3rd party software to be reliable as yet. Particularly not any that hooks into the system because of the changes to the extension framework that creates a locked down system volume.

0

As I wrote earlier, the problem is not in beta 1. This happened after cleaning and removing TeamViwer through the program Cleanmymac X. In safe mode, the same error.
Please Help

0

I have encountered something similar using CleanMyMac X for removing something (I don't remember what though). My Mac booted ok though, but I had to reinstall the software that Cleanmymac had removed to make the problem go away.

0

Strange that this still happens during a safe mode restart??!!

From a Google search it looks like there may be a bundle that hasn't been deleted and is trying to activate software that has been deleted. If you can't boot in safe mode you may have to boot in recovery mode then use Terminal to search for, and remove, the bundle at:

/Library/Security/SecurityAgentPlugins/TeamViewerAuthPlugin.bundle

If that doesn't exist, then the problem could be that something during startup is trying to reference that non-existent bundle. That might be trickier to determine and might need help from TeamViewer Support.

@kiwigraham

Please help I am having the same problem , I am now in recovery mord terminal but cant find the Security folder

@rishabh_goel
Based upon the resolution reported above by @fromfargo, it sounds like you may need to ADD the missing bundle (while in Recovery mode) back in to the folder:
/Library/Security/SecurityAgentPlugins

**At your own risk**, if you don't have any other source for this bundle (ie. please first try and find a copy in your own backups), I have placed a zipped copy of the one found on my 10.14 Mac here: https://app.box.com/s/omrqigvzr9hao5icejuo73nxajmg5pbb

I have looked at the contents of the bundle via BBEdit and can't see anything personalised, but it is possible that it may contain version numbering that still causes a problem for you. (That file needs to be unzipped after downloading.)

You may need to create the SecurityAgentPlugins folder to place it into. Properties of mine are:
drwxr-xr-x 3 root wheel 96 8 Dec 2018 SecurityAgentPlugins

Final note.... If you have also installed the macOS 10.15 beta, and if all of the above seems too complex for you, then I would respectfully suggest that you restore & revert to your macOS 10.14 backup. Beta releases are difficult to debug and shouldn't be used as one's "daily driver".

@kiwigraham @kiwigraham

found the folder but how will i copy the file from my other computer

0
image

0

At this point Alexander, I think I would boot from a clone (hopefully you made one before trying the beta) and just reformat the drive and reinstall from scratch Catalina beta 1.

0

Sorry, I appreciate that English might not be easy for you, but that screenshot doesn’t give me any more information about what you found. (Looks like you found the bundle elsewhere & copied it onto an installer USB and you were trying to then copy it into the boot volume?)

Also, I’m still confused about the version of macOS. The subject title indicates “10.15 beta 1” but you later say that’s not the problem. 10.15 pretty certainly has a different security framework so if you *are* using that version of macOS the problem may be something completely new.

I have the same issue I used clean my Mac X, can someone please help me, I’m desperate.

@ines Have you read the thread above? If you did read it but it didn’t make any sense then instructions provided here may be too complicated.
But in essence, from previous comments, it sounds like one has to restore a file from backup or different machine.... while booted into recovery mode.

0

Hey Everyone,

I am facing the same issue. I have been into two apple stores and both have been useless. Annoyingly I cant boot into Safe Mode.

Any support would be amazing. I run an online coffee company so any help can be rewarded with coffee!!!

Thanks

0

Hello.

Please, someone help me..... I have the same problem because of using Cleanmymac and trying to install Catalina today. But also I tried to start my Mac with recovery mode (command + R) and think it was a mistake. Before it my Mac showed me my userpic, background of Catalina, I inserted my password and after all this error appeared. Now, after my attempts to restart with recovery mode I just see the screen which propose me to change and reset my password. Moreover, when I used command + R, my Mac did not show me the usual screen with utilities, just the screen « reset password ». 
please, don’t know what to do. I’m not a programmer or technician....

Share: