Forum

Permissions ?  

   RSS

0

(This is a Hackintosh related question, but I'm hoping the issue is "permissions" or "OS" related. Not hardware related)

Config: High Sierra 10.13.6, and the Hackintosh is set to be an iMac 14,2

The other day there was a heavy storm and my modem got "zapped" and in turn took out the Hackintosh I was using. Along with an Airport Express, and a ethernet hub.

Fortunately, I had enough spare parts to build another Hackintosh, so I was able to transfer the HDDs over to it and get going again. Kinda.

I have run into a problem though:

For example, one app I run is SMARTReporter (which I got off the App Store) which is not happy 🙁

When it launches it needs me to sign into the App Store which I do, then I get the error:

An unexpected error occurred while signing in.

Your device or computer could not be verified. Contact support for assistance.

I also get an error when I try to launch iTunes:

"An unknown error occurred (-50)"

"I also get an -50 error when I try to download iOS app updates"

Can anyone suggest any fixes ?

regards

Pete...

1 Answer
0

Isn't fun to be able to answer your own question ?

Turns out it was Permissions, but an Ethernet Port "ID" error.

Somehow the two existing ethernet ports were numbered 5 & 6 (as if I had 6 ethernet ports) so I deleted /Library/Preferences/SystemConfiguration/NetworkInterfaces.plist, and then rebooted and recreated an ethernet port (en0) and now the Hack is happy.

Thank you Google.

It seem the Mac App Store and iTunes Store expect to be contacted on en0 and if the ethernet port isn't en0 then things break...

This post was modified 6 months ago by furbies
Share: