Forum

Photos app failing to export & refusing to drag & drop  

  RSS

1

This problem is happening in the Photos app on a client's MacBook Air running 10.13.6.

She has an album of selected holiday snaps that we've been trying to export so she can share them with friends. Her Photos library is stored on an external SanDisk SSD (500GB, HFS+) because the internal drive on the MBA doesn't have enough space.

When we select the full 802 photos in the album then try to drag & drop onto the desktop the cursor appropriately says that all 802 will be deposited. But once that operation has started if we click on the export progress "pie chart" icon it tells us that just 122 photos are being exported (and if we let it go to completion that is indeed all that are copied). If we subsequently retry any drag & drop operation within that same session of Photos, whether it be all 802 or 1 or 2 or 15, the Photos app mostly (but not always) refuses to acknowledge the "drag". ie. no change of cursor & no action performed when doing the "drop". 

If we use the File > Export > (modified) method and choose high quality jpg with the 802 photos selected the operation initiates and the progress bar indicates 802 photos being processed but when it gets to around 250 (not consistent) it would seem to get an error of some sort and quickly pretends to process the remainder (but we again end up with only a partial set) and the Photos app then crashes. I've taken a quick look at the crash report but nothing in it jumps out at me and the fact that it doesn't crash until after the pretence of processing the remaining photos makes me think it might not have any useful context anyway.

These symptoms exhibit for both the desktop and an external USB as the destinations. I have run the built-in repair function on the library with no change to symptoms.

I used FatCat's Power Photos to create a clean Photos library on the external SSD and used its drag & drop to successfully copy the 802 photos into that test library. (Note: Power Photos actually works by sending commands to the Photos app.) However performing the drag & drop or export from that test library exhibits the same symptoms!

I then tried the File > Export > Unmodified originals method and, although it took a long time, it "processed" all 802. But to add a twist.... in the destination folder Finder initially reported just 800 items and then after a couple of minutes (while I was talking to my client) it changed its mind and said there were now 801 items.

 

So, I can't come up with a consistent idea of where the error is living. Is it a particular corrupt photo that then corrupts the Photos working memory, is it the library indexing structure, is it a bug in the Photos app, or is it some strange symptom related to the library being on an external (HFS+) SSD?

 

We do want to have an answer but I also have to be mindful that I've spent several hours on this problem without success and can't charge my client for all that time and taking control of her machine for another couple of hours of testing exacerbates that unpaid work ratio. (And some of the testing options aren't available as I'm having to do this remotely, via TeamViewer.) 

 
1

Huh... that's an interesting one. You tried all of the things I would think to try... and since it's happening with multiple destinations it's (probably) safe to say that the issue is not with the drive itself.

And since you tried with a new library, that mitigates any chance of library corruption. If you run Console do you see anything in the logs there that indicates an error? Photos is usually pretty good about that.

Also, perhaps booting in safe mode, just to see if there's something about that, too. Maybe some other startup process or third-party Extension is getting in the way, though off the top of my head I can't imagine what that would be! 😉

Thanks @davehamilton, I should have though to bring up the console! Running the steps in Safe Mode is worth a try but that reminds me of a "wrinkle" to this machine/situation....

Back when I first confirmed the drag & drop from Photos was playing up, I asked my client to perform a Safe Mode restart to maybe zap any crazy cache files. When she did this the MBA locked up on a grey screen after the initial Apple icon and we had to hard shutdown. This happened twice - and I've never seen this before unless normal boot is also having problems. So we booted normally which got her to her desktop and when I got in via TeamViewer I noticed that her backup USB hard drive, for Time Machine, was no longer visible on the desktop - it had definitely been there prior to us trying the safe mode restart. Disk Utility also failed to show the USB storage device (yes, I definitely had devices listed in the left sidebar) even after a normal shutdown/restart, so I couldn't reformat. System Information did show the device in the list of USB connections. Again working on this issue remotely limited my tool set for diagnosing further so my client bought another external drive for which we successfully configured & executed TM backups (including backing up the external photos SSD).

I'm assuming (or maybe I should say hoping) that Safe Mode locked up trying to run some sort of check on that external drive connection and that it was the checking/repairing that found the drive was bad, rather than caused the drive to go bad. If we do a safe mode restart again I'm going to make sure that during the startup phase we have no external devices attached!

If I was on-site I'd be plugging the external SSD into my own MBP to see if the symptoms followed the library. But I can think of further tests I should/can do with export of other sets of photos that don't include any from the album we've been working with. It all takes time though!

Given we have some new members - I'm just giving this a "bump" to see if there are any other suggestions. At this stage it is likely my client will take her MBA and the hard drive in to a local Mac repair place so they can do better isolation testing.

Share: