Forum

Respect the DND!  

  RSS

0
On all of my devices, Do Not Disturb isn't being respected. I have a scheduled DND from 10pm to 7am and yet in the middle of the night (2:39am to be exact), my Mac lit up AND bonged when the Messages app received a message.
 
Yesterday I was trying to record that video of my iPhone so I turned on DND and I kept getting Telegram messages.
 
This is really aggravating - anyone else have this problem?
 
1

Regarding the Mac, is there a possible process that wakes your Mac up during the period?   I have my DND on my Mac to engage when the Mac Screen is sleeping.  Maybe the Mac is woke by a process and at that point the sky is the limit.

Additionally,  I limit the Apps that can make a sound to Mail and iMessage on my Mac.  From there I really try to curb the number of notifications per app, thus to answer your question related to the Mac, No I don't have this problem. 

For iOS my DND setting for silence is Always.  So if you have it set to While iPhone is locked, well it won't block a notification while in DND, its not that sophisticated regarding screen recordings, like with the Mac.  Given that feature is only a year old, maybe Apple will address that in iOS 12.  Thus to answer your question related to my iOS device I don't have that problem. 

I attached some screenshots of my settings.  Hope that helps.  

 

Screen Shot 2018 06 22 at 1.02.59 PM
Screen Shot 2018 06 22 at 12.55.33 PM
IMG BEA3F411E66B 1
 
1

OOh - that's very interesting @thejtray.  I didn't understand the "Silence while iPhone is locked".  Silence to me meant sound, not notifications.  That's pretty interesting.  Now as far as awakening me when it's supposed to be asleep at night, then the phone IS locked so it shouldn't be waking up.

On the Mac, I went back in to double check my settings, and the darn scheduled DND had gotten shut OFF.  This has happened to me before. I'm often the cause of my own problems but in this case, I'm so aggravated by it waking me up at night I know I wouldn't have turned it off myself!

sigh.

 
1

And my favorite part of this? I had no idea the Mac had a scheduled DnD setting. 

 
2

Off the top of my head the one setting, on iOS, that might bypass DND is the “Allow calls from” setting.  If by chance it is set to “everyone” then I think DND will effectively be ignored for all calls & messages.

So the old trick of flipping that setting might reset a bad plist?

0

Interesting thought, @grahamglebemac-com-au. Maybe that setting could bleed over? I checked mine and it's set to allow calls from Favorites only.  

 
Share: