Forum

SecurityAgent needs to make a change  

  RSS

0

Every time i reboot my MacBook Pro and login to my Standard account. I get the above message and it prompts me for the Admin account and password.

Has anybody else seen this?

 
0

Does the screen/window indicate what that change is? Does it happen if you login to an admin account?

It does not occur if I login using an Admin account. I did a "ps -ef" and it shows:

$ ps -ef | grep Security

    0   156     1   0  5:50PM ??         0:00.60 /System/Library/Frameworks/Security.framework/Versions/A/XPCServices/authd.xpc/Contents/MacOS/authd

    0   328     1   0  5:50PM ??         0:00.23 /System/Library/Frameworks/Security.framework/Versions/A/XPCServices/com.apple.CodeSigningHelper.xpc/Contents/MacOS/com.apple.CodeSigningHelper

  503   469     1   0  5:50PM ??         0:00.04 /System/Library/Frameworks/Security.framework/Versions/A/Resources/CloudKeychainProxy.bundle/Contents/MacOS/CloudKeychainProxy

  502   858     1   0  5:53PM ??         0:00.08 /System/Library/Frameworks/Security.framework/Versions/A/Resources/CloudKeychainProxy.bundle/Contents/MacOS/CloudKeychainProxy

  502  1150     1   0  5:53PM ??         0:00.77 /System/Library/Frameworks/Security.framework/Versions/A/MachServices/SecurityAgent.bundle/Contents/MacOS/SecurityAgent

  502  1345  1328   0  5:55PM ttys006    0:00.00 grep Security

Screen Shot 2019 01 26 at 5.54.19 PM

0

Hi Paul,

I'm currently getting this exact same message. Have you found a solution yet?

Adam

Nope. As I have shown the dialog indicates that it needs to make changes, but there are no indications what the changes are. 

Also, if I login to the MacBook Pro as an Admin account I don't see the issue. 

I have not tried deleting the contents of the /var/folders directory and rebooting which is a solution to a different problem with SecurityAgent.

0

Try booting into safe mode, log into the problem account, then restart and the popup should go away. At least, it worked for me!

I just booted into Safe Mode and logged into the account having problems (Note: It is a Standard Account) and it did not solve the issue. Both in Safe Mode and Normal Mode it continues to prompt me.

Adam,

Did you use Onyx or something else in addition to booting into Safe Mode?

Share: