Forum

Show browser window and Word or Mail at the same time?  

   RSS

0

Since I've switched to Mojave 10.14.3 I am unable to keep my browser window and my email or Word window open on the same desktop. The screen swooshes between them. I can view Mail and Word together. I can view my calendar and Word together. But, I cannot view anything with my browser except my another browser window. I used to be able to keep everything open on the desktop and just toggle between them. How to fix?

3 Answers
0

Do you have your browser running in Full Screen mode?

No. It's seems to swoosh between browser and everything else. I can't keep browser on desktop and open anything else.

So if you press Ctrl- to bring up Mission Control you don't see the browser in another Desktop?

I can see the browser. I can't tile the browser + another application (Word, Calendar, etc.) on the same desktop.

0

Hmm, it certainly sounds like full screen mode, but... that mode wouldn't allow overlapping browser windows either, so it does sound like a setting somewhere has gotten corrupted.

If you've recently done the upgrade/update it might be worth doing a Safe Mode restart (or Onyx cleanup) to clear out caches and "cruft". (I'm assuming you've already tried a normal reboot?)

https://www.macobserver.com/community/mac-questions/step-by-step-non-destructive-resets-smc-nvram-safe-mode/#post-636

Otherwise try flipping the browser into and out of full screen mode.

Also, are you running any 3rd party software for managing window arrangements - like Moom?

I've tried restarting. I'm not running any third party software. It's really bizarre that I cannot get my any browser -- chrome or safari -- to stick to my desktop when I open something else. Any other ideas?

0

Sounds like you might have your browser set to open in its own desktop. Opt-click on the browser icon in the task bar and see what it says under options.

Assign to: This desktop, all desktops, none. If it isn't already, change it to none.

https://www.howtogeek.com/180677/MISSION-CONTROL-101-HOW-TO-USE-MULTIPLE-DESKTOPS-ON-A-MAC/

Screen Shot 2019 03 22 at 12.38.29 PM

Thanks...actually that was the problem...but, it was already assigned to none. I changed to all desktops and that fixed it!

Share: