Forum

Notifications
Clear all

The Great MAC BIOS Debacle on a Mac Pro 2010 dual Quad Core w/ 24GB of ram - no OS

   RSS

0
Topic starter

My beloved Mac Pro had a major failure. Suffice it to say the box will not accept any macOS.  Multiple Mac Repair shops and even more friendly local Mac experts have not been able to suggest a method to load an OS on this box.  Please, rather than telling how to load an OS on this box just accept that it can't be done in its current configuration.  Interesting thing is tried to load Win 10, no luck, but Ubuntu loads and works just fine. 

My assumption is that in upgrading the OS before/after the crash, the loading process wrote code to the BIOS.  And this BIOS is either corrupt (Yes, I Know Ubuntu works) or updated and now is the reason the OS won't load.  

I really want my MAC Pro back running some MacOS.  So, three questions:

1. any suggestions on returning the BIOS to factory default?  The Apple Genius Bar was no help. They were unable to load an OS.  I have not found any mention of restoring the BIOS to default anywhere.  With everything I have tried, the most obvious candidate is still the BIOS.  The Mac Pro has ATI Radeon HD 5780 graphics card. 

2. What hardware (Motherboard BackPlane, graphics card,  or ??) do I need to replace to remove the BIOS from my Mac Pro? 

3. What else might be causing the problem? 

 

Thanks 

 

Artchris0002

Change BIOS to EFI sorry.

2 Answers
0

Incredibly frustrating I’m sure but unfortunately you haven’t given any specifics of what you mean by “not accept any OS”. So I’m wondering if that means that you can’t get any OS X installer to even give a prompt, or if all the installers that have been tried give error messages?

On the hardware front… has the 3V “backup battery” been replaced?

@kiwigraham Sorry. I can run the installers from 10.11 thru 10.13. The systems loads the OS but fails just as it completes the process. I have displayed the console as it loads. The errors change with the OS. One error talked about a font library not found????? This is a default install from the Apple website. and the Hash check was OK. any help/

0

That helps. It’s not that it’s failing to boot, but rather that there are errors when the installer runs. 
The usual culprit for failure in old installers is the system time - in a couple of different ways. But in the first instance of a newly downloaded installer, open Terminal, from Utilities, before running the actual install and check that the system time is correct. If the battery I mentioned above is dead then the clock will be incorrect. Manually set the time if necessary before then running the installer. 

The other time related issue can be with old installers that need the system clock back dated so that their embedded certificate is valid. 

Share: