Forum

Time Machine Question  

   RSS

0

Morning everyone.  I have a question about Time Machine.  I had an ongoing Time Machine backup updating normally in a folder on my Synology NAS, no issues.  Then one day out of the blue, the attached message pops up.  It will not let me resume using the existing sparsebundle which I've been using for months.  It's forcing me to start a new backup. Pretty frustrating given I'm "supposed" to be able to go back in Time Machine.  How good is Time Machine if I have to start a new file every 5-6 months and limited to that time frame?

Any suggestions on what happened to my existing sparsebundle file and how I can continue using it?  It seems I can still go into it and pull files out without issue.

Thanks and don't get caught.  😉

Bill in St. Louis

Screen Shot 2019 05 19 at 9.22.51 AM

0

Using Time Machine to backup over the network to a sparsebundle is prone to errors caused by network disconnects. So the reality is that it is a fact of life that periodically you'll get this message. If it happens frequently you might want to investigate if there are any network related causes.

It is sometimes possible to use disk utility to repair sparsebundles and there are a few help articles out there that give steps for diving a bit deeper on trying to repair. (I have one sparsebundle here that has so far resisted ALL my attempts at repair). The fact that your sparsebundle is still mountable seems promising. But what I generally do when this happens is rename/move the "bad" sparsebundle so that Time Machine doesn't see it anymore at the destination, then let Time Machine start a new one (and not give it the opportunity to delete the old one).

0

Thanks for the input Graham.  Was able to repair it doing some terminal foo as John likes to call it but it all seems for naught.  Finished everything successfully and tried the first TM backup and got the message "Image was read only".  Tried changing the perms but still got the message.  Can't figure out how to get the sparsebundle to read/write.  Guess I will move it to an Archive folder and start over.

Screen Shot 2019 05 19 at 8.19.08 PM

0

I had these kinds of problems with Time Machine and my Macbook back when Time Machine via an Apple File Sharing connection was first made available.

I stopped trying to backup my laptops with Time Machine for this reason.  I still backup my desktop systems via Time Machine and they have remained stable for years, as the physical connections never go away.

My current Synology backup solution is a Rube Goldberg solution.

  • Carbon Copy Cloner mounts an SMB share from my Synology (this is NOT a macOS formatted file system, but the next step gets around that for me)
  • Carbon Copy Cloner then mounts a read/write Sparse Disk Image stored in the SMB share.  The sparse Disk Image "Is" a macOS formatted file system.
  • Carbon Copy Cloner then backups my Mac to the Sparse Disk Image

I this works for me better than Time Machine.  I do have a little history with the Carbon Copy Cloner "Safety Net", but it is not as extensive as Time Machine can give me.

The Synology backup is NOT a bootable clone, but it is my data.

I can make the SMB share accessible from outside my home, and push my backups while on vacation.  Since networked Carbon Copy Cloner is running over an ssh connection, my remote backups are secure.

If you have an older Mac you can dedicate to backup services you can even arrange to run Carbon Copy Cloner on the old Mac, and pull backups from the laptop Mac(s) and store them on the Synology.  This works well when the laptops are at home, but not when you are away from home.

Share: