Forum

Notifications
Clear all

Unable to connect to server

   RSS

0
Topic starter

I have recently moved and am setting up my home network.  I have C-Spire fiber (love the speeds, especially coming from AT&T’s U-verse 75 Mbps).  C-Spire supplies Plume mesh network devices to spread my WiFi signal throughout my house.

I am using a ’13 MacBook Pro 13” and a ’19 iMac 27”, both running the latest Big Sur OS, as well as iPads and iPhones.  Until recently, my main printer was an Epson WF-3540 All In One.  I liked this printer because it could do duplex scans, and that it has an SD Card slot that I could scan documents to.  Once there, I could connect to the SD Card and transfer the files to wherever I wanted them.  Long ago, I connected to the printer using Go -> Connect to Server… in the Finder, and dragging the now-connected location to my Finder Sidebar. 

When the printer part of the 3540 finally bit the dust, I decided I wanted these two features again, and settled on an Epson WF-4834.  Setup went smoothly, it prints and scans as expected, but when I went to connect to the USB flash drive I inserted (they dropped the SD slot), I get a “Connection Failed” message.  

I’ve tried connecting via the device’s IP address using SMB (smb://192.168.40.97) and AFP with no luck.  Same with the device’s assigned name.  I can ping the IP address, no problem.  If I connect a printer cable to the device, I can connect to the flash drive, so it’s apparently a WiFi issue, but nothing I’ve been able to find in my Googling has helped.  Epson support finally said it must be in my router settings.  I’m skeptical of that being the issue - I can still connect to my old WF-3540 with ease.  I’ve tried turning off my Firewall, no difference.

I’ve rebooted everything multiple times.  I’ve set the printer up as a Bonjour printer and as an IP printer.  Neither makes a difference.  I’ve reset the printer to its defaults and set it back up again.  I even did an over-the-top restore of Big Sur on the MacBook Pro. "Scan to Computer" from the printer’s on-screen menus works, but that’s not in my normal workflow, and I’d rather be able to address the flash drive from either of my Macs to move the files as needed.

Using my iPad, I have been able to connect to the printer’s flash drive using the Files app, and also using an app called File Explorer.

 

I’m stumped.  Perhaps there’s a solution I’m overlooking? 

3 Answers
0

Makes me wonder what IP address your Mac is on. Perhaps your Mac is on a different subnet and can’t see the printer?

Good guess, but no cigar. Printer is 192.168.40.97, Subnet 255.255.255.0. iMac is 192.168.40.83, Subnet 255.255.255.0. MacBook is 192.168.40.180, and 255.255.255.0.

0
Topic starter

Another data point - I relocated the printer, and connected it via Ethernet.  Still no go.  "Connection Failed" immediately.

0

Check the printer setup screen to see if your lan assigned a different IP address when you changed it to a wired connection. 

I don’t have this printer, but I also suggest poking around all the setup/config screens to see if there some option to expose the usb storage to your lan. Maybe it’s just paranoid programming by epson. 

@cpragman Thanks for the suggestions; the IP address has remained constant throughout my setup efforts. I feel like I’ve pressed every button I could find in the printer’s setup screens, and reset to factory settings and done it all again.still no love.
As an alternative, I’ve begun scanning to the cloud (Dropbox in my case) and pulling the resulting files from there. It works just fine; it’s just a couple extra button presses. But it’s frustrating knowing the USB device should be readable and not being able to do so.

Share: