Forum

Notifications
Clear all

Unapproved Caller/Security Agent, Unrecoverable Error **answers?**  

   RSS

0

2012 MacBook Pro 17 inch, 1tb SSD, 16ram, OS Catalina 10.15.13

After installing the SSD last fall and upgrading at that time to Catalina I have had this odd issue after the machine had been up for more than 1 week.

I reinstalled a clean version of Catalina 2 weeks ago and had left the machine running and sleeping for 2+ weeks only to find today it was stuck in a trio of non stop errors.

 

Unapproved Caller, Security Agent may only be invoked by Apple Software

Unrecoverable error, Security Agent

From the Console crash log: 

MDS - Today

Crashes from Yesterday:

sharedfileistd - Yesterday

mds - Yesterday

mds - Yesterday

apsd - Yesterday

Securityd

Securityd

mds

securityd

Crashes 2 days ago:

maild

maild

3x maild

 

I do have a lot of JewtsamEvents on the 26th,  I have 16gigs shouldn't that be enough memory?  I am not going anything other then surfing the web.

window server wakeups

 

What I have done in the past is to run Onyx, boot into safe mode to run the diagnostic tools, run disk utility, clean up trash and caches.

 

What I haven noticed is Safari eats a lot of memory and is slow.

Brave browser spins the old fans up when I am a active java page/alot of online moveable graphics, games.

Mail has been working and seems to be working much better under Catalina but I think this may be part of the problem.  I have multiple email accounts from Yahoo, Gmail, and Apple.  EachEmail represents different things, 1 is for business, 1 for work, 1 for spam, etc.

 

I know the easiest thing would be to reboot every 2 days and if that is the answer, so be it.  But I would like to know why under Catalina I am having these kinds of errors.  Reminds me a bit of the System 9 days when the computer would just freeze and lock.   

 

Any input would help, thank you.

Buck

 

4 Answers
0

No answer yet...

 

Today My 2012 MacBook Pro restarted while I was away from my desk.

This time I had a red stop sign stating my iTunes apple account failed to sign in and I had to renter.    I did that and I am running.

Here is what the console says today

Windowserver

News EXT.  - INSTALLED YESTERDAY AND DELETED IT TODAY

locationnd

mds

securityd

sharedfileistd

 

 

Besides the News EXT for safari what else could I do to correct the other system crashes in this list>

 

@buckaroo
Do you have any kernel panic reports?
Finder -> Go -> Go to Folder -> /Library/Logs/DiagnosticReports
look for files that end in .panic

I do have one from today. Right around the time of the reboot which came after the above.
The following diagnostic followed the kernel panic, photoanalysisd which I will have to investigate.

@buckaroo
If you want to post the .panic file contents (it is not long) I will try to look at it.
.
Reading kernel panics is a bit like reading Tea Leaves, but sometimes it gives a solid clue.

0

 

 

Here is the PASTE BIN link

https://pastebin.com/FWccAV7j via @pastebin

@buckaroo
I've seen this a few times on Catalina systems
.
"panic(cpu 6 caller 0xffffff7fa18f0a8d): watchdog timeout: no checkins from watchdogd in 95 seconds (916 total checkins since monitoring last enabled)
.
And at the moment I cannot point a finger at anything. In many cases, there were no 3rd party kernel extensions or 3rd party RAM.
.
I think it is a hard to track down Catalina bug (because if it was easy, it would be fixed).
.
I'm sorry I cannot be more helpful.

YOU HAVE been very helpful and I appreciate it. It gives me something to start with in researching and it adds to your own observations which may help solve someone else down the road. Thank you!

0

Welp,  after a couple of weeks of trying to salvage my newly minted Catalina with the new SSD I discovered the problem or what I think was the problem.

After repairing, running in safe mode, and all the other helpers we have used here at Maczgeekgab I found a 4 kernel ext's that I did not recognize as essential to my current Catalina OS.  I pulled them out and ran through all the above again.  Etrecheck ran again and showed MAJOR issues with the system and indicated 32bit incompatibilities.    

Well what the heck.

I continued now to work through Etrecheck fixing every error that came up but could not get a full clear and go.

Dealing with the speeding fans, the out of control memory runs, heat, and now this I made the decision I should have done originally.

Clean Install.

So far, working like a charm, no crashes.  I ran Etrecheck for 3 consecutive days an the system is solid.  The one other change that happened during the clean install is the current OS was installed.  I honestly don't know if it was the new update, the clean install to get rid of any flakey plist's or kernel exts, or the minute little changes I made under the recommendations of Etrecheck, but it works and currently I am happy with performance.

0

I made the decision I should have done originally...Clean Install.

@BuckaRoo has your clean install held up? Problem still gone? I've been suffering with this same bug since Catalina first came out, and it just happened to me yesterday on 10.15.6. It's happened to me on 3 different Macs as well -- including 2 that have ZERO 3rd party kexts installed so I don't think this is a bad kext. I will do the clean install but wanted to ask how yours was doing a few months later.  Thanks

@luckman212
Yes, I have not had the issue again after the clean install. Personally I would ALWAYS do a clean install after every major update. With moving to Catalina I had many older bits software that were hidden in deep dark places that tickled and irritated the new OS.

Rune Etre and weed out anything that is flagging that app. If you have the time do the clean installs. I would like to know if the clean install fixed your 2 that had no 3rd party kext's.

FYI, lates problem I am having is with Google mail loosing connectivity in Apple Mail. I am just now starting to dig into that issue. Not a big deal but irritating that connectivity is dropped and it hops in my menu bar telling so.

Luckman, good luck

@BuckaRoo ok good to know, glad it's holding up for you. I ran into that Google issue too at a customer of mine. It was a doozy and never actually got fixed. I just ended up telling her to use the webmail instead, I even opened up tickets with Google and had back and forth for weeks. My conclusion is: Google hates desktop apps and just wants everyone to live inside Chrome all day. Ugh.

Just want to post a followup here: this bug now has a name (at least I think). VMware engineers have identified a kernel memory leak in Catalina, specifically 10.15.6 it seems but not confirmed on that.

slowly but steadily, your machine will just drain out all of its memory until you get a panic. It's not isolated to VMware Fusion, it seems like it could affect any app that makes use of the app sandbox. Running VMs just seems like a faster way to trigger the problem.

more details:
https://communities.vmware.com/message/2973339#2973339

Share: