Forum

Wierd Mouse Activity  

   RSS

0
Hi All,
Hope all is well with you and yours. I’ve been having a weird thing going on with my Mac the last 3 weeks or so, and wanted to bounce it off of you.
What’s happening is, when I select a file (or multiple files), the act of selecting them occasionally “sticks”, as though the mouse “slipped”… so I end up accidentally selecting more files than I wanted, moving a file, or opening them. So to combat this, I have to pause briefly after I’ve selected the file, and then move it.
My info:
- I’m running the latest/final? version of High Sierra, and the only updating I’ve done is with apps and the occasional security update.
-  I’m been using a Kensington wired mouse for a while, and it does not have an accompanying system pref pane. Haven't ever had an issue with it.
- I use PathFinder 7 instead of the Finder. Haven't updated to version 8 because that upgrade has been horrible.
What I haven’t tried yet but will when I get a chance:
- Only using the Finder instead of PathFinder
- Try to replicate it in my test user account
- Trying a different mouse
Any of you seen what I have described?
Thanks in advance,
Greg
2 Answers
1

My best guess is a physical/mechanical issue with the mouse. In that when you click with it the electrical contact is occasionally reacting twice. So definitely if you can test with another mouse that would help isolate that possible cause.

The other thing to check, with respect to software & configuration, are any of the mouse settings within System Preferences > Accessibility. It is possible that one of them (such as double click speed) might have been corrupted and if so, adjusting the settings slightly would usually cause the preference cache file to be refreshed.

PS. If isolation testing does indicate the mouse is at fault, a good old fashioned hard blow of air or bang on the desk might be enough to dislodge dust or other detritus that is affecting the contacts.

This post was modified 5 months ago by Graham McKay
1

To “close the loop” on this topic, as soon as I tried a different mouse, the issue went away. Although the mouse I tried was wireless, and not wired, it was enough to convince me to simply get a new mouse to fix the problem. I connected back the “current” mouse a couple of times, and was able to replicate to issue. The new mouse arrived in the mail yesterday, so I’m looking forward to using it.

Thanks for the followup, @gregsgraphics. I've marked @kiwigraham's answer as the solution. Great stuff!

Share: