Forum

WiFi Just Quit  

  RSS

0

I was using the Mac today like any other day. It as attached to our Comcast Business WiFi that never gives us problems. Well, today, it did. I keep getting a “Password Error” every time I try logging back in. Nothing I know fixes it. I’ve tried rebooting the Mac, forgetting the WiFi. Nothing is working. Our iPad pros and iPhone Xs all connect just fine. I was just surfing on the Mac and it just quit. Any ideas?

2016 MBP running 10.13.6.

I should also mention:

Reset the SMC as a final resolution step. There may be a remote chance the the Wi-Fi network card is simply not power delivered correctly due to incorrect settings in the SMC.

0

What happens if you go into Keychain Access and remove the password for that Wi-Fi network? There might be multiple entries there to remove.

The other thing to try, albeit more of a pain, would be changing the Wi-Fi password itself on the router.

theres something about this that reminds me of another thread with network drive issues.

 
0

Thanks Dave. I’ll try those. I discovered something else. I opened Network Preferences and when I try to login to a wireless network from there, I get a “No IP Address found”. (See attachment)

 
0

6C36B8C9 E618 4C29 81F5 CFF15593B119

 
0

Oh very interesting. That shows that your computer thinks it's connected to Wi-Fi (and authenticated, with the password), but can't get communication from the router's DHCP server.

Is it possible the router is denying requests? And is PixieHollow-Biz2.4 the right network?

Lastly, try highlighting Wi-Fi on that screen and clicking the minus sign to remove it entirely, then click plus and re-add Wi-Fi. Sometimes that can help, too.

 
0

I’m not sure. Our iPad Pros and iPhone Xs are all attached to that network and working flawlessly. 

I tried deleting that WiFi and adding a new one and that didn’t work either.

 
0

I don’t think it’s the network because I’m getting the same results when trying to join other networks, as well.

 
0

4A66D3DE 0CB5 4B5E 8082 3121AC749B4F

Notice it shows “Invalid Password”. I am positive I am using the correct passwords for these networks. Confused...

 
0

Does the wifi work on another account on the same Mac? If so, then it's likely some software problem in your account.

If it doesn't, you may have a hardware problem. (Or else something deep in the operating system is affecting all accounts.) 

 
1

Our iPad pros and iPhone Xs all connect just fine. I was just surfing on the Mac and it just quit. Any ideas?

A few questions first:

  • Does the affected Mac connect to other wifi networks with success? If yes, we know your Mac is ok and generally the software is working as expected.
  • Are you close enough to the wireless network in question when testing connectivity?
  • Have you already restarted the router or unplugged it from power and let it sit for a minute before plugging it back into power and then trying again.
  • Remove and add back the affected network from the Preferred Networks list found in System Preferences > Network > Wi-Fi > Advanced

Remove the affected network using the   icon

You could, as Dave mentioned, remove entries in Keychain having to do with the said network.

I can't think of any other steps right now but you could try this:

  1. In the Finder go the Go menu and choose "Go to folder…"
  2. Paste the following into the resulting text field: /Library/Preferences/SystemConfiguration.
  3. Locate all the files inside the folder (path noted above) that have network or Wi-Fi in their filenames and move those to the desktop (don't leave copies of them behind in the folder). Some of those files may include names like: com.apple.airport.preferences.plist
    com.apple.network.eapolclient.configuration.plist
    com.apple.wifi.message-tracer.plist
    NetworkInterfaces.plist
  4. Restart your Mac
  5. Then try to connect to Wi-Fi again.
  6. Reset SMC if all else fails.

Report back if issues persist.

This post was modified 3 weeks  ago 3 times by Alex Santos
 
Share: