Forum

AppleTV -> HomePod with AirPlay2 on 11.4 : a fist shake!  

  RSS

Ari Laquidara
(@tech_hero)
Active Member MGG Premium Member
Joined: 2 years  ago
Posts: 10
June 15, 2018 11:57 EST PM  

TL;DR -- After failing to stream the NBA Finals on my home media setup and the resulting hours on the phone with Apple Support, Apple confirmed to me that AirPlay 2 is still in beta! So if you have AppleTV and HomePod on 11.3 and rely on your media setup for consistent viewing quality, maybe see if you can avoid the 11.4 update until this bug is fixed.

My home media setup consists of a projector, AppleTV 4th generation,and a HomePod. Since updating to 11.4 I noticed the sound is more finicky to control. I noticed this especially when trying to play the ABC app and watch the NBA Finals on my AppleTV. As much as I tried I couldn't get any volume. The little volume ticker displaying the sound source when you go volume up/down on the remote simply wouldn't show. After fiddling with sound source settings, I noticed AirPlay 2 lets you check multiple sources to output sound to. The rub with this is AirPlay 2 will continually default to a setting where it tries to play volume to BOTH AppleTV and HomePod. However, since AppleTV itself has no native volume control, this seems to brick the ability to control volume altogether. I am able to adjust this to some extent by going into sound settings and unchecking AppleTV, so it only sends volume to HomePod, however this seems to have inconsistent results (Netflix was able to display the volume ticker when a movie or show starts, but other apps not always). I then tried a workaround, pulling the game up in a web browser and then trying to AirPlay to AppleTV & HomePod. This however is flawed because it seems that I can only EITHER stream video to AppleTV OR audio to HomePod from my laptop, but not both. Throwing my hands up I called Apple Support and was escalated to a senior technician. He was quickly stumped and escalated to engineering, who apparently discussed this at a meeting and came back to say that AirPlay 2 was still in beta, and there's nothing that can be done until Apple fixes this in a future software release. I was a bit taken aback by this, as I generally take beta functionality on with a bit of caution -- and would expect important functionality like the basic ability for 2 mainstream products to communicate to be protected until the protocol was out of beta. So there's my word of warning and fist shake! Curious if anyone else has had this occur?


ReplyQuote
Share: